Bug 1419904 - Host state icon indicates down when being activated from maintenance
Summary: Host state icon indicates down when being activated from maintenance
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.4
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Ravi Nori
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 11:24 UTC by Radim Hrazdil
Modified: 2017-12-20 10:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:55:34 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)
Screenshot of a host switched from active mode to maintenance mode and then back to active mode. (35.10 KB, image/png)
2017-02-07 11:24 UTC, Radim Hrazdil
no flags Details
prepare to maintenance (552 bytes, image/png)
2017-02-08 14:25 UTC, Eldan Hildesheim
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 84045 0 master MERGED webadmin: Host state icon indicates down when being activated from maintenance 2017-11-29 11:03:26 UTC

Description Radim Hrazdil 2017-02-07 11:24:10 UTC
Created attachment 1248369 [details]
Screenshot of a host switched from active mode to maintenance mode and then back to active mode.

Description of problem:
When moving a host from maintenance mode, the icon indicating current state says "down" instead of indicating that a transition from maintenance mode is being made. 

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.0.4-0.1.el7
ovirt-engine-webadmin-portal-4.1.0.4-0.1.el7.noarch
firefox-51.0.1-2.fc25.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Have a host in maintenance mode
2. Activate the host

Actual results:
During activation process the state indication icon indicates that the host is down.

Expected results:
The indication icon should indicates that the host was in maintenance mode, but is currently being activated.

Additional info:
Screenshot of a host switched to maintenance mode and being activated again is attached.

Comment 1 Oved Ourfali 2017-02-08 09:37:11 UTC
Eldan - new icon?

Comment 2 Eldan Hildesheim 2017-02-08 14:25:19 UTC
1. The icon for prepare to maintenance is not the one that is currently used.
The good one is the one enclosed (3 red triangles pointing down toward a wrench).
2. For booting we have currently an icon with 3 up triangles. In oVirt project it can be found under:
frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/webadmin/images/vmstatus/starting.png

Comment 3 Eldan Hildesheim 2017-02-08 14:25:59 UTC
Created attachment 1248618 [details]
prepare to maintenance

Comment 4 Radim Hrazdil 2017-12-14 09:30:44 UTC
Verified that unique and descriptive icon is displayed for each host status. 
RHVM Version 4.2.0-6

Comment 5 Sandro Bonazzola 2017-12-20 10:55:34 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.