Bug 1419932 - gdeploy-2.0.1-9.el6rhs has unresolved dependencies
Summary: gdeploy-2.0.1-9.el6rhs has unresolved dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.2.0
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1351528
TreeView+ depends on / blocked
 
Reported: 2017-02-07 12:32 UTC by Sreenath G
Modified: 2017-03-23 04:58 UTC (History)
11 users (show)

Fixed In Version: gdeploy-2.0.1-11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 04:58:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0483 normal SHIPPED_LIVE gdeploy bug fix and enhancement update 2017-03-23 08:56:29 UTC

Description Sreenath G 2017-02-07 12:32:43 UTC
Description of problem:
gdeploy-2.0.1-9.el6rhs when tried to install throws out unresolved deps on "/usr/bin/bash"

*** package: gdeploy-2.0.1-9.el6rhs.noarch from file:///mnt/redhat/rel-eng/RHGS/3.2.0-RHEL-6-server/2017-02-07.2/RH-Gluster-3.2-Server/x86_64/os
  unresolved deps: 
***      /usr/bin/bash

Version-Release number of selected component (if applicable):
gdeploy-2.0.1-9.el6rhs

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
When trying to install gdeploy-2.0.1-9.el6rhs, its throws out the "unresolved deps:" error

Expected results:
Installation should succeed, there should not be any unresolved install dependencies 

Additional info:

Comment 2 Atin Mukherjee 2017-02-07 12:49:30 UTC
Devyani - can you please check this issue?

Comment 3 Devyani Kota 2017-02-07 16:38:03 UTC
@Atinm, yes, I could reproduce this issue for gdeploy-2.0.1-9.el6rhs build,
on a rhel-6 machine.
Traceback: https://paste.fedoraproject.org/550636/64848831/
The issue seems to be with the wrong path. Looking into it.

Comment 5 Sachidananda Urs 2017-02-11 09:59:04 UTC
This is a RHEL6 specific issue. This is due to a new script added to the repo.
The shebang should have /usr/bin/env bash instead of /usr/bin/bash
The same however does not cause any problem on RHEL7. The commit: https://github.com/gluster/gdeploy/commit/54f500f resolves the issue.

Comment 6 Manisha Saini 2017-02-16 15:22:37 UTC
Verified this bug on gdeploy-2.0.1-11.el6rhs.noarch

As Gdeploy is able to installed successfully on rhel6,hence moving this bug to verified state.

Comment 9 errata-xmlrpc 2017-03-23 04:58:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0483.html


Note You need to log in before you can comment on or make changes to this bug.