Bug 1419943 - Make default etcd container registry independent
Summary: Make default etcd container registry independent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
: 1505646 (view as bug list)
Depends On:
Blocks: 1420510
TreeView+ depends on / blocked
 
Reported: 2017-02-07 13:23 UTC by Marko Myllynen
Modified: 2018-08-01 19:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1420510 (view as bug list)
Environment:
Last Closed: 2018-08-01 19:59:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3245291 None None None 2018-05-02 18:02:35 UTC

Description Marko Myllynen 2017-02-07 13:23:44 UTC
Description of problem:
Default etcd image used with containerized installations is registry.access.redhat.com/rhel7/etcd instead of rhel7/etcd which forces using osm_etcd_image=rhel7/etcd with disconnected installations.

Please consider dropping the hard-coded registry name from the default as is the case with other images already.

Version-Release number of selected component (if applicable):
3.4

Comment 1 Scott Dodson 2017-02-07 13:34:01 UTC
If we do that for Centos and Fedora it will pull docker.io/rhel7/etcd which doesn't exist. If we did the same substitution on registry.access.redhat.com/rhel7/etcd that we do for image streams and templates will that work for you? It's certainly getting confusing either way.

Comment 2 Marko Myllynen 2017-02-07 13:36:52 UTC
Good point re CentOS/Fedora - yes I think the substitution might be the most suitable option here, at least based on my current understanding. Thanks.

Comment 3 Kim Borup 2018-01-08 07:42:02 UTC
Scott, can we get this change implemented we are more and more running into it specially after we focus on image based installs instead of rpm based installs. 

and when osm_etcd_image is not listed in the hosts.examples it gets hard to find. Of cause now we know, but lots of people out there dont..there is a PR for the hosts.example file so it will display osm_etcd_image, but a more generic change for oreg should be made. 

Ture have mad a pr https://github.com/openshift/openshift-ansible/pull/6618

Comment 4 Scott Dodson 2018-01-09 18:41:55 UTC
Merged the examples documentation PR, we can work on this for 3.9.

Comment 5 Scott Dodson 2018-05-02 18:02:35 UTC
*** Bug 1505646 has been marked as a duplicate of this bug. ***

Comment 6 Scott Dodson 2018-08-01 19:59:33 UTC
Checking the example hosts file this seems to be reflected in 3.7+. 

Marking CLOSED


Note You need to log in before you can comment on or make changes to this bug.