Bug 1419945 - Confusing error message in unattended installation if it cannot resolve deps
Summary: Confusing error message in unattended installation if it cannot resolve deps
Keywords:
Status: CLOSED DUPLICATE of bug 979307
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 13:32 UTC by Jaroslav Škarvada
Modified: 2017-02-08 10:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-08 09:11:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
kickstart file (19.60 KB, text/plain)
2017-02-07 14:04 UTC, Jaroslav Škarvada
no flags Details
Console log (58.05 KB, text/plain)
2017-02-07 14:04 UTC, Jaroslav Škarvada
no flags Details
Resolves log (106.65 KB, text/plain)
2017-02-07 14:05 UTC, Jaroslav Škarvada
no flags Details

Description Jaroslav Škarvada 2017-02-07 13:32:45 UTC
Description of problem:
In unattended installation if it cannot resolve dep it shows confusing error message and switches to interactive mode.

Version-Release number of selected component (if applicable):
anaconda 21.48.22.93-1

How reproducible:
Always

Steps to Reproduce:
1. Try to install package in unattended installation mode which has unresolved dep

Actual results:
[!] Software selection (Source changed - please verify)

Expected results:
Some better error message

Additional info:
We have trouble with this behavior in Beaker jobs. It was hard to debug for us what's the real problem behind and it blocked unattended machine provisioning.

Comment 1 Jaroslav Škarvada 2017-02-07 14:04:30 UTC
Created attachment 1248401 [details]
kickstart file

It seems the problem is tuned-profiles-nfv package which requires qemu-kvm-tools-rhe which is not available.

Comment 2 Jaroslav Škarvada 2017-02-07 14:04:51 UTC
Created attachment 1248402 [details]
Console log

Comment 3 Jaroslav Škarvada 2017-02-07 14:05:31 UTC
Created attachment 1248403 [details]
Resolves log

Comment 4 Jiri Konecny 2017-02-07 15:34:20 UTC
Just a small note, this is not a non-interactive installation. To start non-interactive installation you need to set `cmdline` instead of `text` in a kickstart file, nevertheless you are right about the message.

The problem happens in "tui/spokes/software.py: checkSoftwareSelection()". We need to give user better message when exception DependencyError is raised. This exception is propagated to `status` property where it is processed as invalid transaction now.

Thank you for reporting this,
Jirka

Comment 5 Samantha N. Bueno 2017-02-08 09:11:22 UTC
We'll be addressing this in 7.4. Duping to the approved bug.

*** This bug has been marked as a duplicate of bug 979307 ***


Note You need to log in before you can comment on or make changes to this bug.