Bug 1419964 - When there are v6 IPs only, 'IP Address' column shows no IP address at all
Summary: When there are v6 IPs only, 'IP Address' column shows no IP address at all
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.2
: 4.2.2.1
Assignee: Ales Musil
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 14:12 UTC by Jiri Belka
Modified: 2018-03-29 11:16 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-4.2.0-0.0.master.20171110114816.gitda39b87.el7.centos.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-29 11:16:28 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
rule-engine: exception+


Attachments (Terms of Use)
ipv6 address missing in 'IP Address' column (90.66 KB, image/png)
2017-02-07 14:12 UTC, Jiri Belka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 83196 0 master MERGED core: Extract IPv6 address from Guest Agent Interface and rename Vm IP Address column 2017-10-26 12:53:32 UTC
oVirt gerrit 85921 0 master ABANDONED virt, net: Add support for reporting IPv6 from guest agent data 2018-01-09 08:06:12 UTC
oVirt gerrit 86092 0 master MERGED core: Disable fetching IPs from vdsm guestIps 2018-02-07 08:53:36 UTC
oVirt gerrit 87570 0 ovirt-engine-4.2 MERGED core: Disable fetching IPs from vdsm guestIps 2018-02-14 13:48:58 UTC

Description Jiri Belka 2017-02-07 14:12:50 UTC
Created attachment 1248404 [details]
ipv6 address missing in 'IP Address' column

Description of problem:

When there are v6 IPs only, 'IP Address' column shows no IP address at all. It seems 'IP Address' column is IPv4-only.

See screenhost.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.1.0.4-0.1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install Windows VM with ovirt-guest-agent
2. Have only IPv6 enabled inside VM network settings
3. check reported data for the VM in Network subtab
4. check if there is any IP in 'IP Address' column in VM main tab for the VM

Actual results:
no IP at all

Expected results:
IPv6 address should be visible

Additional info:
thus columnt should probably be renamed to 'IP Addresses' and should display both v4 and v6 IPs.

Comment 1 Dan Kenigsberg 2017-08-15 11:03:08 UTC
Sorry for the late response, but can you help us understand where is the bug (ovirt-engine, vdsm or ovirt-guest-agent)

Is the IPv6-only address reported in guestIPs by
`vdsm-client Host getAllVmStats` ?

Comment 2 Jiri Belka 2017-08-22 07:15:51 UTC
(In reply to Dan Kenigsberg from comment #1)
> Sorry for the late response, but can you help us understand where is the bug
> (ovirt-engine, vdsm or ovirt-guest-agent)
> 
> Is the IPv6-only address reported in guestIPs by
> `vdsm-client Host getAllVmStats` ?

It seems to be engine/wedadmin issue as two IPv6 addresses are visible in the right bottom part of the screenshot - those are IPs reported by GA and we visible in getVmStats $vmid.

I suppose 'IP Address' column in Admin Portal which should display IPs handles only IPv4. Thus I would recommend to check this first.

Comment 3 Michael Burman 2017-10-30 07:07:53 UTC
Testing this on 4.2.0-0.0.master.20171029154613.git19686f3.el7.centos give me some weird results. 
IPv6 doesn't shows in the IP addr column, only IPv4. In some attempts it showed the IPv6 for a second and then it's gone again.

Comment 4 Dan Kenigsberg 2017-10-30 07:32:59 UTC
Burman, can you share what vdsm reports vs what is shown in UI and over REST?

Comment 5 Michael Burman 2017-10-30 08:27:46 UTC
(In reply to Dan Kenigsberg from comment #4)
> Burman, can you share what vdsm reports vs what is shown in UI and over REST?

REST - Report's the IPv6 addresses -

<ips>
<ip>
<address>10.35.1x.x</address>
<version>v4</version>
</ip>
<ip>
<address>fe80::200:ff:xxxx:xx</address>
<version>v6</version>
</ip>
<ip>
<address>2001::3</address>
<version>v6</version>
</ip>
</ips>


UI - In the IP address column i see only IPv4 address and under the VM's Guest agent sub tab i see both IPv4 and IPv6(as always was)

vdsm - 
root@camel-vdsa ~]# vdsm-client VM getStats vmID='534063f0-ec2a-4232-84b1-5b2c82868225' | grep netIfaces -A 10
        "netIfaces": [
            {
                "name": "eth0", 
                "inet6": [
                    "fe80::200:ff:xxxx:xx", 
                    "2001::3"
                ], 
                "inet": [
                    "10.35.1xx.xxx", 
                    "4.4.4.4"

Comment 6 Jiri Belka 2017-10-31 16:36:05 UTC
strange, i saw ipv6 link address for a "while" and then it disappeared from web ui - ovirt-engine-webadmin-portal-4.2.0-0.0.master.20171029154613.git19686f3.el7.centos.noarch

Comment 7 Ales Musil 2017-11-01 13:09:32 UTC
Yeah. It is weird. I'll have to investigate it further. Till then moving to MODFIED.

Comment 8 rhev-integ 2017-11-02 13:38:42 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: infra@ovirt.org

Comment 9 Jiri Belka 2017-11-03 15:34:50 UTC
seems like moved back to ON_QA by mistake.

Comment 10 Ales Musil 2017-11-07 09:24:55 UTC
Yes, it was moved automatically.

Comment 11 Red Hat Bugzilla Rules Engine 2017-11-13 07:23:51 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 12 Dan Kenigsberg 2017-11-17 23:09:13 UTC
Please retest, now that bug 1512572 is fixed.

Comment 13 Michael Burman 2017-11-29 06:25:30 UTC
(In reply to Dan Kenigsberg from comment #12)
> Please retest, now that bug 1512572 is fixed.

Dan, this bug shouldn't be ON_QA.
Jiri Hi, i'm not sure if you already tested this report after Dan moved it again to ON_QA, but it wasn't fixed. The IPV6 address still appear for few seconds and then it's gone. Relevant for  - 4.2.0-0.0.master.20171127212333.git11e14b9.el7.centos

Thanks,

Comment 14 Jiri Belka 2017-11-29 09:23:59 UTC
based on #13 (i haven't test that personally.)

Comment 15 Dan Kenigsberg 2018-02-13 09:24:28 UTC
Actually, it is not yet merged to the stable ovirt-engine-4.2 branch.

Comment 16 Michael Burman 2018-02-19 07:16:50 UTC
Same thing on 4.2.2-0.1.el7
IPv6 addresses got disappeared after few seconds. Only ipv4 remain in the column.

Comment 17 Michael Burman 2018-02-22 13:34:41 UTC
Only now, on the new d/s build this is really fixed. 4.2.2.1-0.1.el7 seems to be fine now.

Comment 18 Jiri Belka 2018-02-22 13:42:05 UTC
ok, ovirt-engine-webadmin-portal-4.2.2.1-0.1.el7.noarch, ovirt-engine-webadmin-portal-4.2.2.1-0.1.el7.noarch

Guest Agent Data:

Name eth0
IPv4 N/A
IPv6 fe80::21a:4aff:fe01:3f22, 2620:52:0:2588:21a:4aff:fe01:3f22
MAC 00:1a:4a:01:3f:22

Admin portal (Vms):

...
jbelka-kickstarttest | | slot-6b | fe80::21a:4aff:fe01:3f22 2620:52:0:2588:21a:4aff:fe01:3f22 | ...
...

Comment 19 Sandro Bonazzola 2018-03-29 11:16:28 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.