Bug 1419986 - Second %packages section in KS drops --ignoremissing from the first section
Summary: Second %packages section in KS drops --ignoremissing from the first section
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 14:55 UTC by Jaroslav Škarvada
Modified: 2021-01-15 07:31 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 07:31:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
kickstart file (19.21 KB, text/plain)
2017-02-07 14:55 UTC, Jaroslav Škarvada
no flags Details

Description Jaroslav Škarvada 2017-02-07 14:55:43 UTC
Created attachment 1248419 [details]
kickstart file

Description of problem:
This was quite surprising for me and should be at least documented.

Version-Release number of selected component (if applicable):
anaconda 21.48.22.93-1

How reproducible:
Always

Steps to Reproduce:
1. Use kickstart from the attachment

Actual results:
You have specified that the group 'desktop-platform-devel' should be installed. 
This group does not exist.  Would you like to ignore this group and continue 
with installation?      

Expected results:
Not sure, maybe just correct documentation of the multiple %packages section (which I wasn't able to find), because the above message is quite confusing.

Additional info:
What's happening:
The first %packages section with --ignoremissing is adding tuned-profiles-nfv which requires qemu-kvm-tools-rhev package which doesn't seem to be available (well the package could be skipped because of the --ignoremissing, but I understand that you cannot do much with the yum depsolver thus the option --ignoremissing is not working for the deps). The second %packages section tried to workaround the problem by adding -tuned-profiles-nfv. But it's missing --ignoremissing option which causes the --ignoremissing to be dropped from the first section and the unattended installation failed becuase there is no 'desktop-platform-devel' group required by the first %packages section.

Comment 3 RHEL Program Management 2021-01-15 07:31:31 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.