Bug 1419987 - kibana-ops resources are created when no ops instances are deployed
Summary: kibana-ops resources are created when no ops instances are deployed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 14:57 UTC by Johan Swensson
Modified: 2020-04-23 23:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 16:28:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Johan Swensson 2017-02-07 14:57:43 UTC
Description of problem:
When creating a default EFK stack some kibana-ops are still created.

Version-Release number of selected component (if applicable):
3.4.1

How reproducible:
Every time

Steps to Reproduce:
1. Deploy according to documentation
Make sure to not define any ops variables.

$ oc export configmap logging-deployer
apiVersion: v1
data:
  es-cluster-size: "1"
  es-instance-ram: 1G
  kibana-hostname: kibana.cloudapps.example.com
  public-master-url: https://openshift.example.com:8443
kind: ConfigMap
metadata:
  creationTimestamp: null
  name: logging-deployer


2.
$ oc get all | grep ops


routes/logging-kibana-ops   kibana-ops.example.com               logging-kibana-ops   <all>     reencrypt

svc/logging-es-ops           172.30.207.176   <none>        9200/TCP   50m
svc/logging-es-ops-cluster   172.30.105.134   <none>        9300/TCP   50m
svc/logging-kibana-ops       172.30.229.129   <none>        443/TCP    50m


3.

Actual results:
ops resources created

Expected results:
When a cluster admin deploys without the ops components it's reasonable to expect that no such resources should be created.


Additional info:

Comment 1 Jeff Cantrill 2017-02-07 15:28:29 UTC
@Eric, this is consistent with the deployer behavior since inception. With the introduction of openshift-ansible, we only create the resources we need.  Do you see it worth the effort to fix for 3.4.  I'm inclined to not fix given the availble resources .

Comment 4 Jeff Cantrill 2017-02-10 16:26:21 UTC
*** Bug 1421021 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Cantrill 2017-02-10 16:28:18 UTC
Closing as we are unlikely to fix in 3.4 given the fact the resources exist does not really cause any issues.  This behavior has been corrected in 3.5 with the move to Ansible.


Note You need to log in before you can comment on or make changes to this bug.