Bug 1419989 - hammer fails with Gem::LoadError (Could not find 'unicode-display_width'...)
Summary: hammer fails with Gem::LoadError (Could not find 'unicode-display_width'...)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.2.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 14:59 UTC by Lukas Pramuk
Modified: 2017-02-07 18:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 18:27:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lukas Pramuk 2017-02-07 14:59:33 UTC
Description of problem:
any hammer run fails with Gem::LoadError due to missing gem dependency 'unicode-display_width'.

Version-Release number of selected component (if applicable):
@Sat6.2.8 Snap1 (candidate)
tfm-rubygem-hammer_cli-0.5.1.13-1.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run hammer
# hammer
/opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/dependency.rb:315:in `to_specs': Could not find 'unicode-display_width' (>= 0) among 166 total gem(s) (Gem::LoadError)
Checked in 'GEM_PATH=/opt/theforeman/tfm/root/usr/share/gems:/opt/rh/rh-ror41/root/usr/share/gems:/root/.gem/ruby:/opt/rh/rh-ruby22/root/usr/share/gems:/opt/rh/rh-ruby22/root/usr/local/share/gems/opt/rh/rh-ror41/root/usr/share/gems:/opt/rh/rh-ruby22/root/usr/local/share/gems', execute `gem env` for more information
	from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/specification.rb:1311:in `block in activate_dependencies'
	from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/specification.rb:1300:in `each'
	from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/specification.rb:1300:in `activate_dependencies'
	from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/specification.rb:1282:in `activate'
	from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:67:in `block in gem'
	from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:66:in `synchronize'
	from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:66:in `gem'
	from /usr/bin/hammer:22:in `<main>'

Actual results:
Gem::LoadError

Expected results:
no errors


Note You need to log in before you can comment on or make changes to this bug.