Bug 1420126 - Custom Attributes not refreshing in Report's Available Fields
Summary: Custom Attributes not refreshing in Report's Available Fields
Keywords:
Status: CLOSED DUPLICATE of bug 1392379
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Jiri Stefanisin
URL:
Whiteboard: report
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 22:27 UTC by Ian Tewksbury
Modified: 2017-05-19 14:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-19 14:10:13 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Ian Tewksbury 2017-02-07 22:27:49 UTC
Description of problem:

I have added Custom Attributes to a VM but those new Custom Attributes are not showing up in the Available Fields selection when creating a new Report


Version-Release number of selected component (if applicable):

5.7.0.17.20161219135818_725f92f

How reproducible:

Always


Steps to Reproduce:
1. Use Automate to add a Custom Attribute to a VM
2. Create a new report
3. The Custom Attribute is not listed in the Available Fields

Actual results:

The Custom Attribute is not listed in the Available Fields


Expected results:

The Custom Attribute should be listed in the Available Fields


Additional info:

I had some Custom Attributes already the first time I ever opened the Reports UI and they show up in the Available Fields. But any new Custom Attributes do not show up in the UI since then.

This also seems to be a problem for the Tag Categories.

Comment 2 Ian Tewksbury 2017-02-07 22:32:10 UTC
As a workaround:

I logged onto a different worker that had UI enabled and was able to see the refreshed list of Custom Attributes there.

Comment 3 Ian Tewksbury 2017-02-08 13:35:54 UTC
Better work around:

If after adding new custom attributes to a VM you do a `systemctl restart evmserverd` on the UI appliance you are logged into then the new Custom Attributes will show up in the Available Fields for reports.

My hunch here is that the list of Available Fields is populated once the first time it is opened after an evmserverd restart and is loaded form cache after that. Besides seeing that a restart fixes the issue this hunch is compounded that after a restart the Available Fields dialog box takes 15-20 seconds longer to load the first time it is ever opened then any subsequent opening, whether on a new or existing report.


Note You need to log in before you can comment on or make changes to this bug.