Bug 1420159 - Cursor leaves a residual image in Motif TextField
Cursor leaves a residual image in Motif TextField
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: motif (Show other bugs)
7.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
: ZStream
Depends On:
Blocks: 1420851 1479818 1508768 1508769
  Show dependency treegraph
 
Reported: 2017-02-07 20:38 EST by Jos Collin
Modified: 2018-04-10 13:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1508768 1508769 (view as bug list)
Environment:
Last Closed: 2018-04-10 13:58:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cursor Residual Image Demo (20.98 KB, application/zip)
2017-02-07 20:38 EST, Jos Collin
no flags Details
A simpler test case image (1.79 KB, image/png)
2017-05-23 10:01 EDT, Carlos Soriano
no flags Details
A simpler test case program (1.02 KB, application/zip)
2017-05-23 10:02 EDT, Carlos Soriano
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0959 None None None 2018-04-10 13:59 EDT

  None (edit)
Description Jos Collin 2017-02-07 20:38:09 EST
Created attachment 1248532 [details]
Cursor Residual Image Demo

Description of problem:
In the attached code, if XmNmarginWidth=1 then the TextField shows a cursor residual image, when the focus on TextField is lost. If XmNmarginWidth=3, then there is no residual image. The residual image appears only for XmNmarginWidth < 3.

Version-Release number of selected component (if applicable):
2.3.4 - 8.el7

How reproducible:
The reproducer code is attached.

Steps to Reproduce:
1. Unzip Attachment2 [details].zip
2. chmod +x make_Text.sh
3. ./TextFieldTest

Actual results:
The cursor leaves a residual image when the TextField loses focus.


Expected results:
The cursor should not leave a residual image for the TextFields created with XmNmarginWidth < 3.

Additional info:
Comment 5 Carlos Soriano 2017-05-23 10:01 EDT
Created attachment 1281563 [details]
A simpler test case image
Comment 6 Carlos Soriano 2017-05-23 10:02 EDT
Created attachment 1281565 [details]
A simpler test case program
Comment 16 Carlos Soriano 2017-09-18 10:02:59 EDT
Hello Deepu,

Sorry for the delay, here it is https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14069096
Comment 26 errata-xmlrpc 2018-04-10 13:58:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0959

Note You need to log in before you can comment on or make changes to this bug.