Bug 1420225 - Help|Install New Software doesn't work
Summary: Help|Install New Software doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Roland Grunberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 08:58 UTC by Avi Kivity
Modified: 2017-02-18 18:20 UTC (History)
8 users (show)

Fixed In Version: eclipse-4.6.2-7.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-18 18:20:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Avi Kivity 2017-02-08 08:58:34 UTC
Description of problem:


Help|Install New Software doesn't work (nothing happens).

Version-Release number of selected component (if applicable):
eclipse-emf-runtime-2.12.0-1.fc25.noarch
eclipse-mylyn-tasks-bugzilla-3.21.0-1.fc25.noarch
eclipse-epp-logging-2.0.3-2.fc25.noarch
eclipse-abrt-0.0.3-1.fc25.noarch
eclipse-jgit-4.6.0-2.fc25.noarch
eclipse-emf-core-2.12.0-1.fc25.x86_64
eclipse-usage-4.4.3-0.1.fc25.noarch
eclipse-pde-4.6.2-6.fc25.x86_64
eclipse-equinox-osgi-4.6.2-6.fc25.x86_64
eclipse-e4-importer-0.2.0-0.2.gitb33919c.fc25.noarch
eclipse-jdt-4.6.2-6.fc25.noarch
eclipse-swt-4.6.2-6.fc25.x86_64
eclipse-filesystem-1.0-7.fc24.x86_64
eclipse-ecf-core-3.13.3-1.fc25.x86_64
eclipse-platform-4.6.2-6.fc25.x86_64
eclipse-mylyn-3.21.0-1.fc25.noarch

I also have self-compiled CDT installed (CDT master + two parser patches)


How reproducible:
Always

Steps to Reproduce:
1. Help|Install New Software

Actual results:

Error logging window


Expected results:

Install new software dialog


Additional info:

!ENTRY org.eclipse.ui 4 0 2017-02-08 10:52:09.071
!MESSAGE Unhandled event loop exception
!STACK 0
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
        at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
        at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
        at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
        at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
        at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
        at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
        at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
        at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
        at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
        at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
        at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5227)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1340)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4561)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4151)
        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
        at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
        at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NullPointerException
        at org.eclipse.equinox.internal.p2.ui.dialogs.RepositorySelectionGroup.fillRepoCombo(RepositorySelectionGroup.java:324)
        at org.eclipse.equinox.internal.p2.ui.dialogs.RepositorySelectionGroup.setRepositorySelection(RepositorySelectionGroup.java:268)
        at org.eclipse.equinox.internal.p2.ui.dialogs.AvailableIUsPage.initializeWidgetState(AvailableIUsPage.java:443)
        at org.eclipse.equinox.internal.p2.ui.dialogs.AvailableIUsPage.createControl(AvailableIUsPage.java:161)
        at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:175)
        at org.eclipse.equinox.internal.p2.ui.dialogs.ProvisioningOperationWizard.createPageControls(ProvisioningOperationWizard.java:384)
        at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:696)
        at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:588)
        at org.eclipse.jface.window.Window.create(Window.java:426)
        at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1095)
        at org.eclipse.equinox.p2.ui.ProvisioningUI.openInstallWizard(ProvisioningUI.java:225)
        at org.eclipse.equinox.p2.ui.ProvisioningUI.openInstallWizard(ProvisioningUI.java:203)
        at org.eclipse.equinox.internal.p2.ui.sdk.InstallNewSoftwareHandler.doExecute(InstallNewSoftwareHandler.java:31)
        at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler.doExecuteAndLoad(PreloadingRepositoryHandler.java:121)
        at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler$1.run(PreloadingRepositoryHandler.java:68)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler.execute(PreloadingRepositoryHandler.java:66)
        at org.eclipse.equinox.internal.p2.ui.sdk.InstallNewSoftwareHandler.execute(InstallNewSoftwareHandler.java:1)
        at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:295)
        at org.eclipse.ui.internal.handlers.E4HandlerProxy.execute(E4HandlerProxy.java:90)
        at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
        ... 37 more

Comment 1 Mat Booth 2017-02-08 09:17:07 UTC
(In reply to Avi Kivity from comment #0)
> 
> I also have self-compiled CDT installed (CDT master + two parser patches)
> 


This part is interesting -- did you try removing it to see if this is causing the problem?

I don't see the problem with only Fedora packages installed.

Comment 2 Avi Kivity 2017-02-08 09:24:39 UTC
I'm afraid to remove it, as I might not be able to reinstall it later.

I would guess it's not directly part of the problem (it doesn't show up in the trace), but perhaps the long history of these two installations confused Install New Software.

Comment 3 Mat Booth 2017-02-08 09:49:45 UTC
(In reply to Avi Kivity from comment #2)
> I'm afraid to remove it, as I might not be able to reinstall it later.
> 
> I would guess it's not directly part of the problem (it doesn't show up in
> the trace), but perhaps the long history of these two installations confused
> Install New Software.

Can you try logging in as a different user to see if Eclipse still exhibits the problem?

This should eliminate the involvement of any custom plugins you have installed in your own ~/.eclipse area.

Comment 4 Roland Grunberg 2017-02-08 15:23:28 UTC
I'm pretty sure I know what the issue is.

It's failing in the new patch created to filter out droplet entries from the dropdown. One of the update sites doesn't have a path.

As a workaround, you could try going into Window -> Preferences. Under Install/Update, go to Available Software Sites, and remove any update sites that aren't valid URLs, or local file paths.

Comment 5 Avi Kivity 2017-02-09 09:08:33 UTC
A non-URL, non-file-path is exactly what I wanted to install from (a local zip archive).  Unzipping it somewhere and installing from that worked.

Comment 6 Roland Grunberg 2017-02-09 16:04:42 UTC
If you're able to reproduce the issue, could you try updating to https://koji.fedoraproject.org/koji/buildinfo?buildID=839511 and see if it still occurs ? You would only need to download the same packages you already have on your system (eg. eclipse-pde, eclipse-equinox-osgi, eclipse-jdt, eclipse-swt, eclipse-platform).

Comment 7 Avi Kivity 2017-02-09 17:20:12 UTC
I am able and I'll try to do it on my other machine (the desktop is happy using the plain (non-archive) repo).

Comment 8 Avi Kivity 2017-02-10 12:27:10 UTC
Confirmed that the fix works for me.

Comment 9 Fedora Update System 2017-02-13 15:59:19 UTC
eclipse-4.6.2-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e540e18c6

Comment 10 Fedora Update System 2017-02-14 00:54:16 UTC
eclipse-4.6.2-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e540e18c6

Comment 11 Fedora Update System 2017-02-18 18:20:39 UTC
eclipse-4.6.2-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.