Bug 1420257 - Build request for CentOS/RHEL
Summary: Build request for CentOS/RHEL
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: sphinx
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1420243
TreeView+ depends on / blocked
 
Reported: 2017-02-08 09:57 UTC by Martin Juhl
Modified: 2017-02-22 05:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-22 05:51:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Juhl 2017-02-08 09:57:27 UTC
This is a request for building "sphinx" against EPEL7, as this is needed for the COPR project.

I'm willing to assist in the testing and maintaining of this package

Comment 1 Pavel Raiskup 2017-02-08 14:45:04 UTC
$ mock -r epel-7-x86_64 --install yum
...
$ mock -r epel-7-x86_64 --shell
python-catkin-sphinx.noarch : Sphinx plugins for Catkin projects
python-ipython-sphinx.noarch : Sphinx directive to support embedded IPython code
python-oslo-sphinx.noarch : OpenStack Sphinx Extensions
python-repoze-sphinx-autointerface.noarch : Auto-generate Sphinx API docs from Zope interfaces
python-sphinx-doc.noarch : Documentation for python-sphinx
python-sphinx-theme-openlmi.noarch : OpenLMI theme for Sphinx documentation generator
python-sphinx_rtd_theme.noarch : Sphinx theme for readthedocs.org
python-sphinxcontrib-adadomain.noarch : Ada domain for the Sphinx documentation generator
python-sphinxcontrib-cheeseshop.noarch : Sphinx extension cheeseshop
python-sphinxcontrib-httpdomain.noarch : Sphinx domain for documenting HTTP APIs
python-sphinxcontrib-issuetracker.noarch : Sphinx integration with different issue trackers
python-sphinxcontrib-napoleon.noarch : Sphinx napoleon extension
python-sphinxcontrib-spelling.noarch : A spelling checker for Sphinx-based documentation
python2-sphinx-theme-alabaster.noarch : Configurable sidebar-enabled Sphinx theme
python34-sphinx-autobuild.noarch : Watch a Sphinx directory and rebuild the documentation
python34-sphinx-theme-alabaster.noarch : Configurable sidebar-enabled Sphinx theme
python-cornice-sphinx.noarch : Generate documentation for Web Services
python-numpydoc.noarch : Sphinx extension to support docstrings in Numpy format
python-sphinx.noarch : Python documentation generator
python2-breathe.noarch : Adds support for Doxygen xml output to reStructuredText and Sphinx
python2-sphinxcontrib-programoutput.noarch : Extension to insert output of commands into documents
python34-breathe.noarch : Adds support for Doxygen xml output to reStructuredText and Sphinx

Comment 2 Gerald Cox 2017-02-13 14:18:20 UTC
Sphinx provides rpms for EPEL.  
They can be found here:  http://sphinxsearch.com/downloads/release/

Comment 3 Pavel Raiskup 2017-02-13 14:51:20 UTC
External RPMs are no-go IMO.  We need to have self-standing repositories,
that's what the bug is about (and also the parent bug).

I'm afraid this is invalid bug however, because I see some python-*sphinx*
packages available in epel-7-x86_64 chroot.

Comment 4 Gerald Cox 2017-02-13 14:59:09 UTC
(In reply to Pavel Raiskup from comment #3)
> External RPMs are no-go IMO.  We need to have self-standing repositories,
> that's what the bug is about (and also the parent bug).
> 
> I'm afraid this is invalid bug however, because I see some python-*sphinx*
> packages available in epel-7-x86_64 chroot.

My comment was intended for people who were running EPEL and wanted to install Sphinx and come across this bug.  It's an option.

Comment 5 Pavel Raiskup 2017-02-13 14:59:47 UTC
Got it, thanks Gerald.

Comment 6 Martin Juhl 2017-02-16 08:55:23 UTC
Is the python-sphinx package the same as sphinx???

Comment 7 Pavel Raiskup 2017-02-16 09:50:15 UTC
Ah, OK -- those are different things..  though I was not aware the need for
'sphinx'.  Is that really needed, or is that just unused dependency for
copr sources?

Comment 8 Martin Juhl 2017-02-21 14:31:58 UTC
Both the copr-backend and the copr-backend-doc package builds fine without the sphinx package...

I'll create a PR for leaving it out for EPEL7..

Comment 9 Pavel Raiskup 2017-02-22 05:51:35 UTC
Turns out sphinx package is not needed for copr:
https://pagure.io/copr/copr/pull-request/40


Note You need to log in before you can comment on or make changes to this bug.