Bug 1420338 - perl-IPTables-libiptc-0.52-19.fc26 FTBFS: Missing support for iptables-1.6.1
Summary: perl-IPTables-libiptc-0.52-19.fc26 FTBFS: Missing support for iptables-1.6.1
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-IPTables-libiptc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 13:31 UTC by Petr Pisar
Modified: 2017-02-08 14:13 UTC (History)
2 users (show)

Fixed In Version: perl-IPTables-libiptc-0.52-20.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-08 14:13:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Pisar 2017-02-08 13:31:10 UTC
perl-IPTables-libiptc-0.52-19.fc26 fails to build in F26:

cc -O2 -Wall -Wunused -I/include -I/usr/include -I../include/ -fPIC -DXTABLES_INTERNAL -g -DIPTABLES_VERSION=\"1.4.4\" -DXTABLES_LIBDIR=\"/usr/libexec/xtables\" -DIPTABLES_VERSION_CODE=\67073 -c -o iptables.o iptables-detect-version.c
iptables-detect-version.c:65:2: error: #error "The libxtables is newer than this package support and know of - Sorry!"
 #error "The libxtables is newer than this package support and know of - Sorry!"
  ^~~~~
iptables-detect-version.c:66:2: error: #error " Please inform the package author of this issue, thanks! "
 #error " Please inform the package author of this issue, thanks! "
  ^~~~~

This is caused by upgrading iptables-devel from 1.6.0-3.fc26 to 1.6.1-1.fc26.


Note You need to log in before you can comment on or make changes to this bug.