Bug 142034 - hwbrowser opens and then crashes
Summary: hwbrowser opens and then crashes
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: hwbrowser (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-06 20:37 UTC by John Poelstra
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 13:22:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Poelstra 2004-12-06 20:37:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
call "hwbrowser" from a command line in run level 5 returns the
following error messages:

Traceback (innermost last):
  File "/usr/share/hwbrowser/DeviceList.py", line 164, in ?
    reread_device_type_clist ()
  File "/usr/share/hwbrowser/DeviceList.py", line 133, in
reread_device_type_clist
    row = clist.append ([hardware.get_category_string (key)])
  File "/usr/share/hwbrowser/DeviceList.py", line 83, in
get_category_string
    return self.type_mapping[key]
KeyError: 20


Version-Release number of selected component (if applicable):
hwbrowser-0.3.5-2

How reproducible:
Always

Steps to Reproduce:
1. Call hwbrowser from a command line
2.
3.
    

Actual Results:  crashes

Expected Results:  displays hardware information

Additional info:

Comment 1 John Poelstra 2004-12-06 20:39:50 UTC
running 2.1-U6 (12/3) release candidate

Comment 2 Nils Philippsen 2005-08-19 10:06:08 UTC
Do you have me some information on what hardware you're seeing this?

Comment 3 John Poelstra 2006-01-16 01:30:10 UTC
I believe it wasn't hardware specific, but had something to do with the way
hwbrowser is wrapped.

Comment 4 Nils Philippsen 2007-01-25 13:22:34 UTC
Can't reproduce this, closing.


Note You need to log in before you can comment on or make changes to this bug.