Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1420344 - [ceph-ansible]: "take-over-existing-cluster.yml" looks for group_vars/all.yml in the local directory
Summary: [ceph-ansible]: "take-over-existing-cluster.yml" looks for group_vars/all.yml...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 2
Assignee: Sébastien Han
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 13:50 UTC by Tejas
Modified: 2017-02-08 22:04 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-08 22:04:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tejas 2017-02-08 13:50:12 UTC
Description of problem:
    WHen I run  "take-over-existing-cluster.yml" it fails with:

ERROR! vars file group_vars/all.yml was not found

However we have the group_vars placed at: as per the latest ansible settings
ceph-ansible]# ll /etc/ansible/group_vars/
total 72
-rw-r--r--. 1 root root   504 Feb  1 19:37 agent.yml.sample
-rw-r--r--. 1 root root  3126 Feb  1 19:37 all.docker.yml.sample
-rw-r--r--. 1 root root 14146 Feb  8 13:39 all.yml
-rw-r--r--. 1 root root   310 Feb  1 19:37 ceph-fetch-keys.yml.sample
-rw-r--r--. 1 root root   785 Feb  1 19:37 clients.yml.sample
-rw-r--r--. 1 root root   577 Feb  1 19:37 common-coreoss.yml.sample
-rw-r--r--. 1 root root   269 Feb  1 19:37 iscsi-gws.yml.sample
-rw-r--r--. 1 root root  1067 Feb  1 19:37 mdss.yml
-rw-r--r--. 1 root root  2833 Feb  6 14:34 mons.yml
-rw-r--r--. 1 root root  2322 Feb  1 19:37 nfss.yml.sample
-rw-r--r--. 1 root root  5364 Feb  6 14:34 osds.yml
-rw-r--r--. 1 root root  1641 Feb  1 19:37 rbd-mirrors.yml.sample
-rw-r--r--. 1 root root   737 Feb  1 19:37 restapis.yml.sample
-rw-r--r--. 1 root root  1364 Feb  1 19:37 rgws.yml

The "take-over-existing-cluster.yml" should reflect this change in the group_vars placement.


Version-Release number of selected component (if applicable):
ceph-ansible-2.1.6-1.el7scon.noarch

How reproducible:
Always

Comment 2 seb 2017-02-08 15:24:25 UTC
From where are you running this playbook? Which path? Are you running under infrastructure-playbooks/? You need to move it up.

Comment 3 Christina Meno 2017-02-08 15:45:24 UTC
Seb,

These are the docs for using this playbook. I assume that is what Tejas is using

https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/paged/installation-guide-for-red-hat-enterprise-linux/chapter-3-storage-cluster-installation#ansible-takeover-cluster

Comment 4 Andrew Schoen 2017-02-08 15:58:16 UTC
(In reply to Gregory Meno from comment #3)
> Seb,
> 
> These are the docs for using this playbook. I assume that is what Tejas is
> using
> 
> https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/paged/
> installation-guide-for-red-hat-enterprise-linux/chapter-3-storage-cluster-
> installation#ansible-takeover-cluster

It looks like those docs were written before we moved 'take-over-existing-cluster.yml' into infrastructure-playbooks/.

Tejas,

As a workaround could you try moving infrastructure-playbooks/take-over-existing-cluster.yml up a directory to /user/share/ceph-ansible. You would also need to symlink what you defined in /etc/ansible/group_vars/all.yml to /usr/share/ceph-ansible/group_vars/all.yml.

Once those two steps are done I imagine the playbook will complete successfully.

Thanks,
Andrew

Comment 5 Tejas 2017-02-08 17:00:37 UTC
Gregory, Seb, 
  
    Yes the doc needs to reflect the changes introduced with the ceph-ansible rebase. I will track this in a separate bug.

Andrew,
    The workaround is successful, thanks.

Thanks,
Tejas


Note You need to log in before you can comment on or make changes to this bug.