Bug 1420372 - [UPDATES] Workflow not found [workflow_identifier=tripleo.update.v1.update_plan]
Summary: [UPDATES] Workflow not found [workflow_identifier=tripleo.update.v1.update_plan]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: beta
: 11.0 (Ocata)
Assignee: RHOS Maint
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks: 1394025
TreeView+ depends on / blocked
 
Reported: 2017-02-08 14:28 UTC by Yurii Prokulevych
Modified: 2017-05-17 19:57 UTC (History)
15 users (show)

Fixed In Version: openstack-tripleo-common-6.0.0-2.el7ost python-tripleoclient-6.1.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:57:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 430691 None None None 2017-02-20 13:18:37 UTC
OpenStack gerrit 432357 None None None 2017-02-20 13:19:43 UTC
OpenStack gerrit 432422 None None None 2017-02-20 13:20:37 UTC
Launchpad 1663635 None None None 2017-02-20 13:19:13 UTC
Launchpad 1663698 None None None 2017-02-20 13:20:12 UTC

Description Yurii Prokulevych 2017-02-08 14:28:09 UTC
Description of problem:
-----------------------
Installation of latest RHOS-11 build.
Attempt to update exits with next message:

[stack@undercloud-0 ~]$ yes '' | openstack overcloud update stack -i overcloud
Workflow not found [workflow_identifier=tripleo.update.v1.update_plan]

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-tripleo-heat-templates-6.0.0-0.20170127041112.ce54697.el7ost.1.noarch
openstack-heat-templates-0.0.1-0.20170124165609.15cf0b6.el7ost.noarch
python-tripleoclient-6.0.1-0.20170127055753.8ea289c.el7ost.noarch

Steps to Reproduce:
-------------------
1. Deploy RHOS-11. UC+SSL, OC+SSL+IPv4
2. Setup latest repos
3. Update undercloud
4. Try to update overcloud

Comment 6 Yurii Prokulevych 2017-03-30 13:05:34 UTC
Verified with:
- openstack-tripleo-common-6.0.0-2.el7ost.noarch
- python-tripleoclient-6.1.0-2.el7ost.noarch

openstack overcloud update stack -i overcloud
Started Mistral Workflow tripleo.package_update.v1.package_update_plan. Execution ID: f4384e5b-b36a-4f7a-92d0-50827db76e32
Waiting for messages on queue '4dc51add-00ab-424c-a20a-28aa167a008f' with no timeout.
IN_PROGRESS
WAITING
on_breakpoint: [u'controller-0', u'compute-0', u'ceph-2', u'ceph-1', u'controller-1', u'controller-2', u'compute-1', u'ceph-0']
Breakpoint reached, continue? Regexp or Enter=proceed (will clear eb3fe1de-3141-45cd-9be8-a5a2752d74d2), no=cancel update, C-c=quit interactive mode:

Comment 7 errata-xmlrpc 2017-05-17 19:57:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.