Bug 1420383 - Package LevelDBJNI and use in ODL
Summary: Package LevelDBJNI and use in ODL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 12.0 (Pike)
Assignee: Stephen Kitt
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On: 1432091
Blocks: 1414298
TreeView+ depends on / blocked
 
Reported: 2017-02-08 14:37 UTC by Mike Kolesnik
Modified: 2018-10-18 07:23 UTC (History)
5 users (show)

Fixed In Version: opendaylight-6.0.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
This update replaces the Java based LevelDB in favour of the JNI package and provides the leveldbjni-all-1.8-15.5.el7ost.x86_64 package.
Clone Of:
Environment:
N/A
Last Closed: 2017-12-13 21:08:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github fusesource leveldbjni issues 90 None None None 2017-02-08 15:07:21 UTC
OpenDaylight Bug 7742 None None None 2017-02-08 15:04:49 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Mike Kolesnik 2017-02-08 14:37:17 UTC
Description of problem:
Currently we don't have the JNI package so we're using a Java port of LevelDB.
This Java port isn't well tested and isn't used upstream so we would best avoid resorting to it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
The Java port is used.


Expected results:
The JNI part should be used.


Additional info:

Comment 1 Stephen Kitt 2017-03-01 16:05:46 UTC
http://pkgs.devel.redhat.com/cgit/rpms/opendaylight/commit/?h=private-skitt-remove-dsos&id=ef6752c5dd71f8cd64d62d6c48003a4a04ab2618 implements this, but it needs netty and leveldbjni to be available in RHEL or OSP.

Comment 5 Stephen Kitt 2017-07-13 12:15:05 UTC
The candidate build for this is https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=13652244

Comment 7 Stephen Kitt 2017-07-13 12:48:35 UTC
Return to POST since the candidate build isn’t done yet...

Comment 8 Itzik Brown 2017-09-13 08:39:15 UTC
Checked with:

leveldbjni-all-1.8-15.5.el7ost.x86_64
opendaylight-6.1.0-2.el7ost.noarch

1. Checked that opendaylight package is installed

2. $ rpm -q --whatrequires leveldbjni-all                  
opendaylight-6.1.0-2.el7ost.noarch

3. Checked that akka.conf has
 # native = off

Comment 14 errata-xmlrpc 2017-12-13 21:08:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.