Bug 1420399 - switch Requires: /etc/httpd/conf.d to Requires: httpd-filesystem
Summary: switch Requires: /etc/httpd/conf.d to Requires: httpd-filesystem
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-HTML-Mason
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 14:51 UTC by Igor Gnatenko
Modified: 2017-02-12 19:07 UTC (History)
4 users (show)

Fixed In Version: perl-HTML-Mason-1.56-8.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-12 09:31:18 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1420385 0 unspecified CLOSED gallery3 should not own /etc/httpd/conf.d 2021-02-22 00:41:40 UTC

Internal Links: 1420385

Description Igor Gnatenko 2017-02-08 14:51:23 UTC
Unfortunately at this point we don't have guidelines which prohibit adding directory dependencies, but I will work on this.

It's quite common that other packages own same directory, there's no problem for it. Which means you will end up with different packages installed on system...

For example, gallery3 co-owns /etc/httpd/conf.d which makes perl-HTML-Mason to pull it instead of httpd-filesystem.

Comment 1 Ralf Corsepius 2017-02-08 15:16:03 UTC
(In reply to Igor Gnatenko from comment #0)
> Unfortunately at this point we don't have guidelines which prohibit adding
> directory dependencies, but I will work on this.
We do have guidelines on this. Multiple ownerships are explicitly allowed.
 
> It's quite common that other packages own same directory, there's no problem
> for it.
Correct.

> Which means you will end up with different packages installed on
> system...
... which means the installer doesn't handle such situations correctly.

> For example, gallery3 co-owns /etc/httpd/conf.d which makes perl-HTML-Mason
> to pull it instead of httpd-filesystem.
I think a viable solution in this case would be to remove this requires and let perl-HTML-Mason also own it.

Comment 2 Igor Gnatenko 2017-02-08 15:32:12 UTC
(In reply to Ralf Corsepius from comment #1)
> (In reply to Igor Gnatenko from comment #0)
> > Unfortunately at this point we don't have guidelines which prohibit adding
> > directory dependencies, but I will work on this.
> We do have guidelines on this. Multiple ownerships are explicitly allowed.
You don't read sentence. I was pointing on Requires on directory, not co-owning directories.
>  
> > It's quite common that other packages own same directory, there's no problem
> > for it.
> Correct.
> 
> > Which means you will end up with different packages installed on
> > system...
> ... which means the installer doesn't handle such situations correctly.
No.
> 
> > For example, gallery3 co-owns /etc/httpd/conf.d which makes perl-HTML-Mason
> > to pull it instead of httpd-filesystem.
> I think a viable solution in this case would be to remove this requires and
> let perl-HTML-Mason also own it.
or change it to Req: httpd-filesystem. Completely up to you. I don't know what this particular package does with it.

Comment 3 Emmanuel Seyman 2017-02-12 09:31:18 UTC
(In reply to Igor Gnatenko from comment #2)
>
> or change it to Req: httpd-filesystem.

Done.

Comment 4 Ralf Corsepius 2017-02-12 19:02:10 UTC
This change is naive and the cause of a regression: Nothing guarantees http-filesystem will provide /etc/httpd/conf.d.

Comment 5 Ralf Corsepius 2017-02-12 19:07:40 UTC
In protest against this change and against  Igor Gnatenko, I am stepping down as maintainer of this package.


Note You need to log in before you can comment on or make changes to this bug.