Bug 14204 - RFE: allow user to see fdisk error messages
Summary: RFE: allow user to see fdisk error messages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 13614 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-18 05:17 UTC by Nitin Dahyabhai
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 15:49:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nitin Dahyabhai 2000-07-18 05:17:31 UTC
When partitioning using fdisk, after writing the new table,
this is output into the text window:

	Calling ioctl() to re-read partition table.

The user has 2 seconds to read that before this appears:

	Re-read table failed with error 16: Device or resource busy.
	Reboot your system to ensure partition table is updated.

	WARNING: If you have created or modified any DOS 6.X
	partitions, please see the FDISK manual page for additional 
	information
	Syncing disks.

3 and a half seconds later, you're back in the installer.  Unless you
have used fdisk lots of times before, you're not going to be able to
read that error message in the time that's given.  You definitely won't
be able to check the fdisk man page.

Perhaps when fdisk returns non-zero, you can ask the user to click
a button to proceed after they read any error messages?

Comment 1 Matt Wilson 2000-07-27 18:19:38 UTC
May be after 7.0


Comment 2 Michael Fulbright 2001-02-08 20:36:26 UTC
*** Bug 13614 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.