Bug 1420400 - Dashboard time zone should display current timezone instead of GMT
Summary: Dashboard time zone should display current timezone instead of GMT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dashboard
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.1.2
: ---
Assignee: Scott Dickerson
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 14:53 UTC by Jason
Modified: 2021-03-11 15:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-24 11:21:45 UTC
oVirt Team: UX
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1278 0 normal SHIPPED_LIVE ovirt-engine-dashboard bug fix and enhancement update for RHV 4.1.2 2017-05-24 15:18:36 UTC
oVirt gerrit 74001 0 master MERGED Use browser default time zone for date time formatting 2021-02-13 12:35:47 UTC
oVirt gerrit 74007 0 ovirt-engine-dashboard-1.1 MERGED Use browser default time zone for date time formatting 2021-02-13 12:35:48 UTC

Description Jason 2017-02-08 14:53:07 UTC
Description of problem:

Dashboard displays a "Refreshed" date/time which does not correspond to the local TZ it is being viewed in. 

Version-Release number of selected component (if applicable):

4.x

How reproducible:

Everytime

Steps to Reproduce:

Open RHV-M go to Dashboard tab

Actual results:

Displays GMT

Expected results:

Display local viewing TZ (Use Browser Default TimeZone)

Comment 2 Marina Kalinin 2017-03-10 17:14:28 UTC
Hey.
1. If this is indeed the case, it should be a bug, not RFE. The dashboard should show LOCAL time. AFAIK, this is standard and expected behavior with any web app.

2. Second, I do not see where it is GMT. Mine shows local time. I have 4.0.4.

Greg, What do you say?

Comment 3 Marina Kalinin 2017-03-10 17:19:15 UTC
However, the customer confirms - they see it in GMT, despite being on CST.

Greg, switching it to bug.
Can you please help us understanding why it is not reproducible on our environments? IS there anything we can do to manually tweak it?

Comment 5 Marina Kalinin 2017-03-10 17:22:07 UTC
From the customer:
~~~
From the manager's CLI:

[root@rhevm] # date
Tue Feb  7 10:41:45 CST 2017

From the dashboard page in the manager's UI:

Last Updated 2/7/2017, 4:42:18 PM GMT
~~~

Comment 6 Greg Sheremeta 2017-03-10 23:58:15 UTC
I think it's a bug and not an RFE. Assigning to Scott

...

cc'ing Oved. In [1], Oved mentions things moving to UTC. I'm not aware of such an effort.

[1] https://www.mail-archive.com/users@ovirt.org/msg38822.html

Comment 7 Scott Dickerson 2017-03-11 00:57:22 UTC
Comment 3 on 1362402 [1] talks about the date/time format following the event log style.  Selecting a TZ of UTC was a conscious choice following the same rationale and to provide consistent display across all users.

We've had subsequent discussions and mails about TZ selection etc.  All of those discussions funneled to an RFE BZ 1417516 [2].

So, UTC is what is currently expected to be formatted.  In the future, it will most likely be an extra drop down on the login screen to select a TZ with either the browser default or UTC (depending on a system config) selected as default.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1362402#c3 
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1417516

Comment 8 Marina Kalinin 2017-03-11 02:56:41 UTC
Scott, very interesting.
However, what is not clear to me - why do we all see it here in our local environments as local time zone (EST, for example), but the customer sees GMT? Did this started happening from specific 4.0.z release? The bug you've pointed out to seem to be 4.1 only.
Can you please help me understanding this?

Comment 9 Marina Kalinin 2017-03-11 03:02:51 UTC
And if indeed I am seeing something wrong, and our environments are somehow wrong and the default behavior is GMT, then we should close this bug as duplicate of bz#1362402 and tell the customer it will be fixed soon in 4.1 GA.

P.S. I believe customer is referring to the refresh time at the top left of the dashboard and not the tooltips that other bug is referring to.

Here it is in customer's words:
"Can the dashboard be manually refreshed?  Also the logs are in CST.  The "Last updated" time on the dashboard is GMT.  Can that be changed to CST?"

Comment 15 Greg Sheremeta 2017-03-13 19:52:36 UTC
We'll sneak this into 4.1.1.

@QE and PM, ack? It takes 1 minute to qa this change, and it's low risk.

Comment 17 Lucie Leistnerova 2017-03-20 14:11:01 UTC
dashboard time changes according to local timezone

verified in ovirt-engine-4.1.1.5-0.1.el7.noarch with ovirt-engine-dashboard-1.1.0-7.el7ev.noarch

Comment 21 errata-xmlrpc 2017-05-24 11:21:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1278


Note You need to log in before you can comment on or make changes to this bug.