Bug 1420403 - firefox.desktop conflicts between attempted installs of firefox-45.1.1-1.el6_7.s390 and firefox-45.7.0-1.el6_8.s390x
Summary: firefox.desktop conflicts between attempted installs of firefox-45.1.1-1.el6_...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1419840
TreeView+ depends on / blocked
 
Reported: 2017-02-08 15:02 UTC by Tomas Pelka
Modified: 2017-02-08 20:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-08 20:59:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tomas Pelka 2017-02-08 15:02:10 UTC
Description of problem:
Output from RPM Command:
	file /usr/share/applications/firefox.desktop conflicts between attempted installs of firefox-45.1.1-1.el6_7.s390 and firefox-45.7.0-1.el6_8.s390x

Version-Release number of selected component (if applicable):
firefox-45.7.0-1.el6_8.s390x

How reproducible:
100%

Steps to Reproduce:
1. update all ff* pkgs
2.
3.

Actual results:
Output from RPM Command:
	file /usr/share/applications/firefox.desktop conflicts between attempted installs of firefox-45.1.1-1.el6_7.s390 and firefox-45.7.0-1.el6_8.s390x

Expected results:
no error

Additional info:

Comment 2 Tomas Pelka 2017-02-08 15:04:25 UTC
Same for ppc64:

Output from RPM Command:
file /usr/share/applications/firefox.desktop conflicts between attempted installs of firefox-45.7.0-1.el6_8.ppc64 and firefox-45.1.1-1.el6_7.ppc

So both arched (s390 and ppc) that were added are affected.

Comment 3 Martin Stransky 2017-02-08 16:49:45 UTC
I believe that's because you upgrade multiarch packages (firefox-45.1.1-1.el6_7.ppc) to non-multiarch one (firefox-45.7.0-1.el6_8.ppc64).

You need to update to firefox-45.7.0-*2*.el6_8.ppc64 and firefox-45.7.0-*2*.el6_8.ppc.

Comment 4 Tomas Pelka 2017-02-08 20:59:57 UTC
So here is my thinking. Last time we shipped s390 and ppc was https://errata.devel.redhat.com/advisory/25943 shipped in Dec 2016 (currently available-1).

FF version: firefox-45.6.0-1.el6_8

So assuming all customers sold have this version. So I took s390 and ppc rpms from mentioned advisory and manually replaced prehistoric firefox-45.1.1-1.el6_7. I believe this is the real situation on customer site.

old files for current QE erratum (skipping debuginfo):
firefox-45.6.0-1.el6_8.s390
firefox-45.7.0-1.el6_8.s390x

new files for current QE erratum (skipping debuginfo):
firefox-45.7.0-2.el6_8.s390
firefox-45.7.0-2.el6_8.s390x

Update works fine, downgrade works although tps complains about mixed pkg state which is expected as versions are really mixed.

This issue from my point of view is not a bug in FF but in ET it self.


Note You need to log in before you can comment on or make changes to this bug.