This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 142041 - KickStart with network --ethtool="..." doesn't quote ETHTOOL_OPTS
KickStart with network --ethtool="..." doesn't quote ETHTOOL_OPTS
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
RHEL3U5
:
Depends On: 142045
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-12-06 16:19 EST by John Kerbawy
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 10:28:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Kerbawy 2004-12-06 16:19:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
While doing a KickStart and passing --ethtool="..." to the "network"
keyword in the KickStart configuration, the resulting value in
ETHTOOL_OPTS isn't quoted properly causing ifup to error on boot.

network --bootproto=dhcp --ethtool="duplex full speed 100"

This little patch seems to fix the problem for me.

--- network.py.orig     2004-12-02 18:59:23.000000000 -0500
+++ network.py  2004-12-02 19:08:28.000000000 -0500
@@ -114,7 +114,7 @@
                s = s + key + "=" + 'no' + "\n"
             # make sure we include autoneg in the ethtool line
             elif key == 'ETHTOOL_OPTS' and
self.info[key].find("autoneg")== -1:
-                s = s + key + "=" + "autoneg off " + self.info[key] +
"\n"
+                s = s + key + """="autoneg off %s"\n""" %
(self.info[key])
            else:
                s = s + key + "=" + self.info[key] + "\n"


Version-Release number of selected component (if applicable):
anaconda-9.1.3-3.RHEL

How reproducible:
Always

Steps to Reproduce:
1. KickStart with network --ethtool="duplex full speed 100"
2. Reboot and view /etc/sysconfig/network-scripts/ifcfg-eth0
3. Run ifup eth0 and watch for "/sbin/ifup: line 4: off: command not
found" because the ETHTOOL_OPTS value isn't quoted.

Actual Results:  See above.

Additional info:

I tested this by modifying network.py and network.pyc in stage2.img,
netstg2.img, and hdstg2.img instead of properly rebuilding anaconda.
 I don't remember where I found out about --ethtool, and maybe it
isn't supported, but the current quoting in network.py doesn't make
sense to me.
Comment 2 Paul Nasrat 2005-01-04 15:19:45 EST
Thanks for the patch commited.  Targetting for U5
Comment 4 Dennis Gregorovic 2005-05-18 10:28:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-191.html

Note You need to log in before you can comment on or make changes to this bug.