Bug 142042 - packaging bug in RHEL3-U4 libstdc++-devel?
Summary: packaging bug in RHEL3-U4 libstdc++-devel?
Status: CLOSED DUPLICATE of bug 135611
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc34 (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-06 21:45 UTC by Dave Maley
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 22:09:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Maley 2004-12-06 21:45:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041130 Firefox/1.0

Description of problem:
problem reported in IT #56355:
------------------------------

It looks like there may be a problem with one of the packages in U4
PPC.  It looks like the problem is in the upgrade logic:

# rpm -Uv /mnt/ppcU4/libstdc++-devel-3.2.3-47.ppc.rpm
Preparing packages for installation...libstdc++-devel-3.2.3-47
error: unpacking of archive failed on file /usr/include/c++/3.2.3/
ppc-redhat-linux/bits/time_members.h;41b4c27d: cpio: link failed -
File exists

# rpm -qf /usr/include/c++/3.2.3/ppc-redhat-linux/bits/time_members.h
libstdc++-devel-3.2.3-42

So RPM is complaining about a file that it is supposed to be upgrading.

Obviously, he has a workaround already. He just was reporting the
problem to be friendly. Thus severity 4.

Version-Release number of selected component (if applicable):
libstdc++-devel-3.2.3-47.ppc.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh libstdc++-devel-3.2.3-47.ppc.rpm
2.
3.
    

Actual Results:  error from RPM

Expected Results:  upgrade package

Additional info:

Comment 1 Jakub Jelinek 2004-12-06 22:09:56 UTC

*** This bug has been marked as a duplicate of 135611 ***


Note You need to log in before you can comment on or make changes to this bug.