Bug 1420457 - firewall-cmd set-log-denied may fail with ALREADY_SET
Summary: firewall-cmd set-log-denied may fail with ALREADY_SET
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld
Version: 7.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On: 845257 1366654 1414584
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 17:22 UTC by Tomas Dolezal
Modified: 2017-08-01 16:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 16:22:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1934 0 normal SHIPPED_LIVE firewalld bug fix and enhancement update 2017-08-01 17:55:15 UTC

Description Tomas Dolezal 2017-02-08 17:22:10 UTC
Description of problem:
ALREADY_ENABLED was changed to return sucess (0) exitcode. this is not the case for repeated --set-log-denied argument

Version-Release number of selected component (if applicable):
firewalld-0.4.4.2-2.fc24.noarch
firewalld-0.4.3.2-8.el7_3.noarch

How reproducible:
always

Steps to Reproduce:
firewall-cmd --set-log-denied off; firewall-cmd --set-log-denied off

Actual results:
Error: ALREADY_SET: off

with EC=34

Expected results:
Warning: ALREADY_set off

with EC=0
Additional info:

Comment 6 errata-xmlrpc 2017-08-01 16:22:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1934


Note You need to log in before you can comment on or make changes to this bug.