Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1420468 - DNF not remove unused dependencies on removing "Extreme Tuxracer" game !
Summary: DNF not remove unused dependencies on removing "Extreme Tuxracer" game !
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 18:08 UTC by yousifjkadom@yahoo.com
Modified: 2018-10-04 18:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-12 19:59:26 UTC
Type: Bug


Attachments (Terms of Use)

Description yousifjkadom@yahoo.com 2017-02-08 18:08:28 UTC
Description of problem:
DNF not recognized not-required packages (dependencies) on removal of a game !

Version-Release number of selected component (if applicable):
1.1.10-4 on Fedora 24 X64 bit Cinnamon edition (it is on it's defauled configuration & not modified by any way: set by default to remove unused dependencies when remove packages)

How reproducible:
- install "Extreme Tuxracer" by GNOME software then remove it.

Steps to Reproduce:
1.install "Extreme Tuxracer"
2.see dependencies packages that dnf ask to install with game
3.now (after finishing installation) try to remove this game. You will see that 2 of dependencies packages will not asked to remove by dnf ! These are:
- extremetuxracer-papercuts-fonts
- extremetuxracer-common

Actual results:
These 2 package (which by definition NOT used by any other application or package) not removed:
- extremetuxracer-papercuts-fonts
- extremetuxracer-common

Expected results:
These 2 packages (being unused dependencies) should removed by DNF when removing extremetuxracer game.


Additional info:

Comment 1 Igor Gnatenko 2017-02-09 10:45:55 UTC
I can't reproduce it on my system. So it highly depends on packages installed.

Please re-run dnf remove extremetuxracer with --debugsolver and attach debugdata directory.

Or if you already have it removed, then run dnf --debugsolver --assumeno autoremove and attach debugdata directory.

Comment 2 yousifjkadom@yahoo.com 2017-02-09 18:20:04 UTC
Hi. Before do what you suggest please:

1) I installed this game by using GNOME software center (that I installed on my system after Fedora project said that they fix bug in Pakagekit which was leading to conflict with DNF), then I remove this game by Yum extender (DNF) package manager. Does this bearing something to you ?

2) If point (1) above not useful to you to see cause of this bug, then before do what you suggest on me, I wish to hear from you that you will remain with me to learn me how to remove debugger files. I perform such test in previous issue but when I tried to remove them I could not & someone suggest on me to remove them by file manager under sudo & I did this but later on I knew that use GUI with sudo is risky & it is safer to remove such files from command line, but I forget how to do this.

Comment 3 Christian Stadelmann 2017-03-20 11:45:40 UTC
(In reply to yousifjkadom@yahoo.com from comment #2)
> Hi. Before do what you suggest please:

Please do run the commands Igor Gnatenko gave you. You can deny running the transactions by pressing "n". It is just the debugsolver data that needs to be generated. Without this data there is no way your bug can be fixed. your (1) and (2) is not helpful.

> 1)
> … then I remove this game by Yum extender (DNF) package manager.

Yum extender should do the same as dnf does.q

> 2)
> I wish to hear from you that you will remain with me to learn me how to remove debugger files.

Which debugger files do you mean?

Do you mean the debugsolver data? It is stored in /root/debugdata if you ran dnf as root. See `man dnf` and search for "--debugsolver" for details.

Or do you mean the debuginfo packages? You can get a list of them by running `dnf list installed \*-debuginfo`. You can uninstall them one by one with `dnf remove [package name]` or all together by running `dnf remove \*-debuginfo`. You can safely remove all debuginfo packages, they are not required for anything essential, only for debugging applications.


Have you upgraded your system from Fedora 24 or earlier? If yes, have you used both dnf and gnome-software on this system prior to upgrading to Fedora 25? If yes, you are probably affected by fallout of bug #1259865. https://fedoraproject.org/wiki/Common_F25_bugs#DNF_upgrade_might_remove_essential_system_packages_if_you_used_PackageKit_.28GNOME_Software.2C_KDE_Apper.29_in_the_past has a suggested workaround, but the only real fix known to me is wiping your OS and reinstalling.

Comment 4 yousifjkadom@yahoo.com 2017-03-20 13:08:27 UTC
No !

1) No, I did not upgrade from Fedora 24 to 25. I installed Fedora 24 & just make system up to date without upgrading to Fedora,

2) No, I did not install & use GNOME software center unless many months passed after fixing bug 1259865. I know this fetal bug & was very careful from it. I waited till publicly announced that it was fixed, then gave additional months (may be 4 or 5 months) before installed GNOME software centre.

Comment 5 Jaroslav Mracek 2017-05-12 19:59:26 UTC
I think your problem was fixed in upstream in dnf-2.4 and gnome software on Fedora 25. DNF-2.4 is available for Fedora 26 and rawhide or can be installed from our testing repository for Fedora 24+ (dnf copr enable rpmsoftwaremanagement/dnf-nightly). Please if you will experience the problem on Fedora 25 with dnf-2.4, don't hesitate to reopen the bug report.

Comment 6 Jeffrey Walton 2018-10-04 18:54:28 UTC
'dnf autoremove' may also help cleanup cruft left behind but is no longer needed.


Note You need to log in before you can comment on or make changes to this bug.