Bug 142047 - ppmtowinicon gives 'out of memory' error for 16x16 images
ppmtowinicon gives 'out of memory' error for 16x16 images
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 16:58 EST by Joe Krahn
Modified: 2013-07-02 19:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 03:49:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Krahn 2004-12-06 16:58:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
ppmtowinicon works gives an out-of-memory error for 16x16 input PPM
images, but succeeds for other sizes.

Version-Release number of selected component (if applicable):
netpbm-10.19-7

How reproducible:
Always

Steps to Reproduce:
1. pbmmake -white 16 16 | pbmtopgm 1 1 | pgmtoppm '#fff' |
ppmtowinicon -o test.ico -

Actual Results:  ppmtowinicon: out of memory

Expected Results:  test.ico file

Additional info:
Comment 1 Jindrich Novy 2004-12-07 03:49:00 EST
Joe, this works for me with netpbm-10.25-3. Please note that the
version you mentioned is in FC2, not in FC3.

To resolve this, please install netpbm-10.25-2 (FC3) or the latest one
from:

http://sunsite.mff.cuni.cz/pub/fedora/development/SRPMS/netpbm-10.25-3.src.rpm

Note You need to log in before you can comment on or make changes to this bug.