Bug 1420470 - Desktop icons stacked on top of each other
Summary: Desktop icons stacked on top of each other
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 18:38 UTC by Derek Daniels
Modified: 2020-01-10 09:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-10 09:12:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Derek Daniels 2017-02-08 18:38:34 UTC
Description of problem:
Upon successful login all user icons are stacked on top of each other in the x0,y0 position. This affects local accounts as well as network accounts. The user is unable to use the right click to open terminal and use basic nautilus features until any window is opened. After which icons are placed randomly on the desktop and the right click options are available.

Version-Release number of selected component (if applicable):
nautilus-3.14.3-12.el7.x86_64

How reproducible:
Reproducible on machines running nautilus-3.14.3-16.el7.x86_64 with patch 13

Steps to Reproduce:
1. Login through gdm to GNOME Classic
2. Icons are stacked on top of each other

Actual results:


Expected results:


Additional info:
We were unable to reproduce the bug on a clean 7.3 install. This seems to be localized to our environment and whatever changes we apply. We rebuilt the nautilus package without patch 13 (icons-on-primary.patch) and the problem was resolved. Could it be possible a requires were missed in the backporting of patches and nautilus is now unable to correctly calculate display size?

Comment 2 Ondrej Holy 2020-01-10 09:12:36 UTC
This was seemingly caused by some change in storing icon positions when rebasing from 3.14 to 3.22 in RHEL 7.4 and possibly relates to Bug 1473610. However, we have now RHEL 7.8 with nautilus 3.26 and thus I think that it is pretty late to do anything with it, so I am going to close this. Rebase from 3.22 to 3.26 is not seemingly affected by this as per my testing.


Note You need to log in before you can comment on or make changes to this bug.