Bug 1420472 - [RFE] skip migration 0020_nested_drpm_directory if there are no DRPMs
Summary: [RFE] skip migration 0020_nested_drpm_directory if there are no DRPMs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks: 1426420
TreeView+ depends on / blocked
 
Reported: 2017-02-08 19:00 UTC by Michael Hrivnak
Modified: 2019-06-13 21:25 UTC (History)
14 users (show)

Fixed In Version: pulp-2.8.7.10-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1426420 (view as bug list)
Environment:
Last Closed: 2017-05-01 13:59:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 2575 Normal CLOSED - CURRENTRELEASE As a user, I don't have to wait for migration 0020_nested_drpm_directory if there are no DRPMs 2017-04-27 14:04:02 UTC
Pulp Redmine 2649 Normal CLOSED - COMPLETE Backport #2575, As a user, I don't have to wait for migration 0020_nested_drpm_directory if there are no DRPMs 2017-03-30 23:07:58 UTC
Red Hat Product Errata RHBA-2017:1191 normal SHIPPED_LIVE Satellite 6.2.9 Async Bug Release 2017-05-01 17:49:42 UTC

Description Michael Hrivnak 2017-02-08 19:00:31 UTC
Description of problem:

This migration walks the entire tree of published RPM repos looking for places to fix incorrectly published DRPMs. This can take a long time, especially on latent filesystems.

Version-Release number of selected component (if applicable):
Sat 6.2

How reproducible:
always

Steps to Reproduce:

Upgrade from 6.1 to 6.2

Actual results:

The migration runs and might take a lot of time.

Expected results:

The migration takes no time when there are no DRPMs, which is the case for most customers.

Comment 2 pulp-infra@redhat.com 2017-02-08 19:31:17 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 3 pulp-infra@redhat.com 2017-02-08 19:31:19 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 4 pulp-infra@redhat.com 2017-02-11 00:31:21 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 5 pulp-infra@redhat.com 2017-02-12 21:01:23 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 6 pulp-infra@redhat.com 2017-02-12 21:31:20 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 7 pm-sat@redhat.com 2017-02-23 21:11:48 UTC
Please add verifications steps for this bug to help QE verify

Comment 10 pulp-infra@redhat.com 2017-03-30 01:32:53 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2017-03-30 01:32:54 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 12 pulp-infra@redhat.com 2017-03-30 23:07:59 UTC
The Pulp upstream bug status is at CLOSED - COMPLETE. Updating the external tracker on this bug.

Comment 13 Roman Plevka 2017-04-04 09:00:52 UTC
VERIFIED
on sat6.2.9-2

- tested both upgrades with and without DRPM, the migration step was indeed skipped with no drpms in place.

Comment 14 pulp-infra@redhat.com 2017-04-17 13:33:14 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 15 pulp-infra@redhat.com 2017-04-27 14:04:03 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 17 errata-xmlrpc 2017-05-01 13:59:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191


Note You need to log in before you can comment on or make changes to this bug.