Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1420474 - goferd conumes 100% cpu after losing the connection to qdrouterd
Summary: goferd conumes 100% cpu after losing the connection to qdrouterd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Qpid
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Unspecified
Assignee: Mike Cressman
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 19:20 UTC by Andrew Kofink
Modified: 2020-12-14 08:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 17:36:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 18386 0 None None None 2017-02-08 19:20:52 UTC

Description Andrew Kofink 2017-02-08 19:20:53 UTC
Description of problem:
goferd continually connects and disconnects to qdrouterd

Version-Release number of selected component (if applicable):
6.2.6

How reproducible:
Intermittent

Steps to Reproduce:
This has been reproduced during errata install via katello-agent with an isolated capsule.
It has also been reproduced with internal capsule, as described in the attached redmine. Restarting goferd on the client has been shown to temporarily fix the issue.

Actual results:
Feb 2 13:49:04 hostname goferd: [INFO][pulp.agent.id-number-hidden] gofer.messaging.adapter.connect:35 - retry in 10 seconds
Feb 2 13:49:14 hostname goferd: [INFO][pulp.agent.id-number-hidden] gofer.messaging.adapter.connect:28 - connecting: proton+amqps://centosrhelupdateserver.domain.tld:5647
Feb 2 13:49:14 hostname goferd: [INFO][pulp.agent.id-number-hidden] gofer.messaging.adapter.proton.connection:87 - open: URL: amqps://centosrhelupdateserver.domain.tld:5647|SSL: ca: /etc/rhsm/ca/katello-default-ca.pem|key: None|certificate: /etc/pki/consumer/bundle.pem|host-validation: None
Feb 2 13:49:14 hostname goferd: [INFO][pulp.agent.id-number-hidden] root:485 - connecting to centosrhelupdateserver.domain.tld:5647...
Feb 2 13:50:17 hostname goferd: [INFO][pulp.agent.id-number-hidden] root:525 - Disconnected
Feb 2 13:50:17 hostname goferd: [ERROR][pulp.agent.id-number-hidden] gofer.messaging.adapter.connect:33 - connect: proton+amqps://centosrhelupdateserver.domain.tld:5647, failed: Connection amqps://centosrhelupdateserver.domain.tld:5647 disconnected

Expected results:
goferd should be able to connect and communicate with pulp

Additional info:

Comment 3 Satellite Program 2017-02-12 09:07:08 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18386 has been resolved.

Comment 4 Mike McCune 2017-05-17 17:36:57 UTC
We are currently shipping qpid-proton-0.9-16 that includes the above mentioned fixes.

The main remaining issue around gofer stability we are still tracking is:

https://bugzilla.redhat.com/show_bug.cgi?id=1318015

Going to close this as currentrelease on 6.2.9 or later. Please re-open if this is still occurring on 6.2.9 or later releases.


Note You need to log in before you can comment on or make changes to this bug.