Bug 1420475 - samba-winbind-krb5-locator packaging conflict prevents update
Summary: samba-winbind-krb5-locator packaging conflict prevents update
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba4
Version: 6.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 19:21 UTC by Przemek Klosowski
Modified: 2017-12-01 12:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-01 12:42:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Przemek Klosowski 2017-02-08 19:21:14 UTC
Description of problem:
 samba-winbind-krb5-locator packaging conflict prevents update. I noticed it first because it blocked a system update. I narrowed it down to samba subsystem and then by 'yum -d 5 update' to this component.

I did 'yum erase samba-winbind-krb5-locator' which allowed the update to complete. I had seen in the past that packaging errors can sometimes be worked around by removing the offending package, updating the rest, and reinstalling, but this time I can't reinstall this one.

Version-Release number of selected component (if applicable):
samba4-winbind-krb5-locator-4.2.10-7.el6_8.x86_64

How reproducible: every time

Steps to Reproduce:
1.yum install samba-winbind-krb5-locator

Actual results:
Loaded plugins: product-id, refresh-packagekit, rhnplugin, search-disabled-repos, security
This system is receiving updates from RHN Classic or RHN Satellite.
Repository google-earth is listed more than once in the configuration
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package samba4-winbind-krb5-locator.x86_64 0:4.2.10-7.el6_8 will be installed
--> Processing Dependency: samba4-libs = 4.2.10-7.el6_8 for package: samba4-winbind-krb5-locator-4.2.10-7.el6_8.x86_64
--> Processing Dependency: samba4-winbind = 4.2.10-7.el6_8 for package: samba4-winbind-krb5-locator-4.2.10-7.el6_8.x86_64
--> Running transaction check
---> Package samba4-libs.x86_64 0:4.0.0-66.el6_6.rc4 will be updated
---> Package samba4-libs.x86_64 0:4.2.10-7.el6_8 will be an update
---> Package samba4-winbind.x86_64 0:4.2.10-7.el6_8 will be installed
--> Processing Dependency: samba4-common = 4.2.10-7.el6_8 for package: samba4-winbind-4.2.10-7.el6_8.x86_64
--> Processing Dependency: libpopt-samba3-samba4.so(SAMBA_4.2.10)(64bit) for package: samba4-winbind-4.2.10-7.el6_8.x86_64
--> Processing Dependency: libpopt-samba3-samba4.so()(64bit) for package: samba4-winbind-4.2.10-7.el6_8.x86_64
--> Running transaction check
---> Package samba4-common.x86_64 0:4.2.10-7.el6_8 will be installed
--> Processing Conflict: samba4-common-4.2.10-7.el6_8.x86_64 conflicts samba-common < 3.9.9
--> Processing Conflict: samba4-winbind-4.2.10-7.el6_8.x86_64 conflicts samba-winbind < 3.9.9
--> Finished Dependency Resolution
Error: samba4-winbind conflicts with samba-winbind-3.6.23-36.el6_8.x86_64
Error: samba4-common conflicts with samba-common-3.6.23-36.el6_8.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
successful installation of package

Comment 2 Andreas Schneider 2017-02-10 10:35:51 UTC
Yes, samba4 is a tech preview on RHEL6. You can only install either samba-winbind or samba4-winbind. The same for the locator plugin.


Why do you want to use the locator plugin from samba4 tech preview?

Comment 3 Przemek Klosowski 2017-02-10 17:23:26 UTC
I had an existing samba install that included this package. During a routine update this package started blocking not only samba update but the entire transaction. I resolved it by deleting this package, with no apparent ill effects.

Comment 4 Andreas Schneider 2017-02-13 16:40:41 UTC
I think we should add an explicit conflict with samba-winbind so that this can't happen by accident again.

Comment 5 Martin Kosek 2017-12-01 12:42:59 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.