Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1420504 - Scrolling is laggy when using two fingers (LibreOffice)
Summary: Scrolling is laggy when using two fingers (LibreOffice)
Keywords:
Status: CLOSED DUPLICATE of bug 1367846
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 20:17 UTC by Alec
Modified: 2017-06-12 13:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-22 16:10:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Alec 2017-02-08 20:17:03 UTC
Description of problem: When scrolling in LibreOffice writer the page will not respond for a couple of seconds and creates a very laggy scrolling effect. Also the page will scroll from side to side when scrolling down/up which is really annoying.


Version-Release number of selected component (if applicable):
Fedora 25

How reproducible:
Very

Steps to Reproduce:
1.Open LibreOffice Writer 
2.Scroll with two fingers
3.

Actual results:
Jagged scrolling. Up/Down and side to side.

Expected results:
Smooth scrolling. Up/Down

Additional info: I am on a high resolution display (3200 * 1800). Scrolling with the side bar is smooth.

Comment 1 Caolan McNamara 2017-02-09 17:05:37 UTC
wrt lag, do you get this even on a blank page, or does it require content to get the lag. I don't notice anything special here.

wrt two finger scrolling, if you put enough line and lettters in gedit, does it behave any differently with side to side, up down scrolling, to me it seems the same. i.e. gtk3 just reports the amount of up and down and side to side movement and both scroll accordingly.

Comment 2 Alec 2017-02-09 21:55:19 UTC
I tested this and I only get the wrt lag in LibreOffice Writer even with a blank page. Gedit is fluid even with a solid page of text so is every other program. Also LibreOffice Writer is only called sOffice in the top bar if that helps(I think that is another bug).

Comment 3 Alec 2017-02-14 20:34:33 UTC
I have been playing around with LibreOffice Writer and I have found that if I scroll extremely slowly then the wrt lagg appears to be almost gone but when I scroll at normal speed the page jumps around.

Comment 4 eaon 2017-04-27 00:06:28 UTC
I'm experiencing this, or a variation of it. Scrolling in LibreOffice Writer is generally not particularly smooth, but everything gets very jumpy when comments (created with Ctrl+Alt+C) are visible. If the document is large enough and has a fair amount of comments, two-finger scrolling becomes unusable.

Comment 5 Caolan McNamara 2017-05-22 16:10:30 UTC
I think this may be the same underlying problem as bug 1367846

*** This bug has been marked as a duplicate of bug 1367846 ***


Note You need to log in before you can comment on or make changes to this bug.