Bug 1420527 - semanage module -d / -e tracebacks
Summary: semanage module -d / -e tracebacks
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1420707
TreeView+ depends on / blocked
 
Reported: 2017-02-08 21:50 UTC by Milos Malik
Modified: 2017-08-01 16:16 UTC (History)
7 users (show)

(edit)
Clone Of:
: 1420707 1594735 (view as bug list)
(edit)
Last Closed: 2017-08-01 16:16:12 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1883 normal SHIPPED_LIVE policycoreutils bug fix update 2017-08-01 17:53:54 UTC

Description Milos Malik 2017-02-08 21:50:31 UTC
Description of problem:
* semanage tracebacks instead of complaining that these options require an additional argument

Version-Release number of selected component (if applicable):
policycoreutils-2.5-12.el7.x86_64
policycoreutils-python-2.5-12.el7.x86_64

How reproducible:
* always

Steps to Reproduce:
# semanage module -d
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 937, in <module>
    do_parser()
  File "/usr/sbin/semanage", line 916, in do_parser
    args.func(args)
  File "/usr/sbin/semanage", line 572, in handleModule
    OBJECT.set_enabled(args.module_name, False)
  File "/usr/lib/python2.7/site-packages/seobject/__init__.py", line 397, in set_enabled
    for m in module.split():
AttributeError: 'NoneType' object has no attribute 'split'
# semanage module -e
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 937, in <module>
    do_parser()
  File "/usr/sbin/semanage", line 916, in do_parser
    args.func(args)
  File "/usr/sbin/semanage", line 570, in handleModule
    OBJECT.set_enabled(args.module_name, True)
  File "/usr/lib/python2.7/site-packages/seobject/__init__.py", line 397, in set_enabled
    for m in module.split():
AttributeError: 'NoneType' object has no attribute 'split'
#

Actual results:
* semanage module tracebacks

Expected results:
* following message appears:
ValueError: You did not define module name

Additional information:
* this is NOT a regression, the same problem exists in RHEL-7.3

Comment 5 errata-xmlrpc 2017-08-01 16:16:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1883


Note You need to log in before you can comment on or make changes to this bug.