Bug 142055 - OO.o: oocalc not associated with .xls files
Summary: OO.o: oocalc not associated with .xls files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 140583
TreeView+ depends on / blocked
 
Reported: 2004-12-06 22:31 UTC by Zack Cerza
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 02:07:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zack Cerza 2004-12-06 22:31:59 UTC
Description of problem:
Calc doesn't seem to be properly associated with MS Excel (.xls) files.

To reproduce this, you'll obviously need a .xls file. Google for '.xls'.

When you right-click on a .xls file in Nautilus, the default might
actually be 'Open with "OpenOffice.org Calc"' - ignore that.

Right-click on the file, and go to 'Properties'. Click 'Open With'.
There isn't anything there. Next send the file to yourself as an
attachment with Evolution. When you click on the little arrow on the
attachment to get a context menu, the only option is 'Save as...'.

'application/vnd.ms-excel' probably just needs to be added to
/usr/share/applications/redhat-spreadsheet.desktop .

Also, it looks like ooimpress is missing powerpoint. If MS has some
sort of 'drawing' format, oodraw needs that too.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-10

Comment 2 Dan Williams 2004-12-07 02:07:57 UTC
This is fixed already in redhat-menus, new builds of OOo later than
1.1.2-12 that get built into 4E will have this taken care of.  Please
check out 1.1.2-14.6.EL4 that's in /mnt/redhat/dist/4E.

(The problem was twofold: redhat-menus provides the actual .desktop
file, but OOo was using 'cp' on that file rather than making a
symlink, hence the need for a rebuild.  The current 4E redhat-menus
has the fix, and so should the current OOo.)

Comment 3 Dan Williams 2004-12-07 02:47:49 UTC
For reference, see Bug 140390 and Bug 137520


Note You need to log in before you can comment on or make changes to this bug.