Bug 1420562 - [anaconda] spurious empty file /1 created during install
Summary: [anaconda] spurious empty file /1 created during install
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On: 1383266
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 00:17 UTC by Lyude
Modified: 2020-09-10 10:12 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1383266
Environment:
Last Closed: 2019-05-29 14:41:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lyude 2017-02-09 00:17:16 UTC
Cloning this bug because I noticed the other day that this is actually present on RHEL 7.3 as well

+++ This bug was initially created as a clone of Bug #1383266 +++

Description of problem:
After installing current Fedora 25 using either the netinst or the live media, the file system exhibits an empty file /1 located at the top level of the file system. Its creation date indicates that it has been created spuriously by the installer and that it is not related to some system service.

Version-Release number of selected component (if applicable):
anaconda-25.20.4-1.fc25

How reproducible:
Always

Steps to Reproduce:
1. Install new Fedora 25 system or simply boot corresponding live media.
2. Check content of top level directory /.

Actual results:
An empty file named "1" is listed together with the usual file-system entries.

Expected results:
No empty file named "1" exists in the top level directory /.

Additional info:
This issue was absent from the official Fedora 24 live image Fedora-Workstation-Live-x86_64-24-1.2.iso but it -does- appear in recent live images such as F24-x86_64-WORK-20161009.iso.

--- Additional comment from Chris Murphy on 2016-10-12 02:40:44 EDT ---

Yes I see this on a clean installation of Fedora-Workstation-Live-x86_64-25-20161008.n.0.iso

--- Additional comment from Nick Clifton on 2016-12-16 07:25:00 EST ---

Hi Chris,

  I am having trouble reproducing this. :-(  Can you tell me which of the binutils rpms is installing this file ?  (binutils, binutils-devel, binutils-debuginfo).

Cheers
  Nick

--- Additional comment from Chris Murphy on 2016-12-16 11:06:49 EST ---

binutils is the only one of those I have installed

The empty file /1 is actually found on the official live install media: Fedora-Workstation-Live-x86_64-25-1.3.iso

# mount /dev/mapper/live-base /run/install/source

IF you 'ls -l /run/install/source' you'll see the empty 1. So it's just getting rsync'd by the installer. There's no way now to get rid of it.

A separate problem is a clean install of Fedora 25 fully updated has an empty file 'null' in the root directory, dated dec 12. I've deleted it (again), we'll see if it reappears, but reinstalling binutils doesn't cause it to come back.

--- Additional comment from Dr. David Alan Gilbert on 2016-12-16 11:23:55 EST ---

Yeh I guess that 'null' probably is a separate problem - but I've got it as well; from what I can tell from my logs the timestamp is about the time I shutdown on the 12th.

--- Additional comment from Chris Murphy on 2016-12-16 12:54:40 EST ---

See bug 1405568 for empty file null.

--- Additional comment from Chris Murphy on 2017-01-19 15:54:04 EST ---

This is still happening on Rawhide installations. 

Fedora-Workstation-Live-x86_64-Rawhide-20170110.n.0.iso 
binutils-2.27-13.fc26.x86_64

--- Additional comment from Joachim Frieben on 2017-01-25 04:24:44 EST ---

This issue is solved for all of Fedora 25 network install, current Fedora 25 live media F25-WORK.x86-64-20170120, and current Fedora 26 (rawhide).

It is certainly not a binutils issue, because the latter has not changed in Fedora 25 since Aug 2016, and yet, the issue has disappeared.


Note You need to log in before you can comment on or make changes to this bug.