Bug 1420569 - Fedora 25 networking-guide section 9.2 has wrong package name for the dhcp-server package.
Summary: Fedora 25 networking-guide section 9.2 has wrong package name for the dhcp-se...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: networking-guide
Version: devel
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Stephen Wadeley
QA Contact: Fedora Docs QA
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 00:41 UTC by stolidmollusc
Modified: 2017-07-11 20:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-11 20:01:25 UTC


Attachments (Terms of Use)

Description stolidmollusc 2017-02-09 00:41:59 UTC
Description of problem: Wrong package name given in Section 9.2. Configuring a DHCP Server.  The document instructs users to install package 'dhcp'; the correct package name is 'dhcp-server'.


Version-Release number of selected component (if applicable): 25

How reproducible: Read section 9.2 at https://docs.fedoraproject.org/en-US/Fedora/25/html/Networking_Guide/sec-dhcp-configuring-server.html

Steps to Reproduce:
1. See the first few lines about how to install a dhcp server.

Actual results:  The document states:
"The dhcp package contains an Internet Systems Consortium (ISC) DHCP server. Install the package as root:

~]# dnf install dhcp

Installing the dhcp package creates a file, /etc/dhcp/dhcpd.conf, ..."


Expected results:  All mentions of the 'dhcp' package should be changed to the 'dhcp-server' package.  I found just the 3 instances quoted above.


Additional info:  At least since Fedora 24, 'dhcp-server' is the package that provides the documented component.

Comment 1 Stephen Wadeley 2017-07-11 20:01:25 UTC
Thank you for raising this bug


commit f9904fa17799ddf0141693d4a4b737c3ba6f5877
Author: Stephen Wadeley <swadeley@redhat.com>
Date:   Tue Jul 11 21:59:54 2017 +0200

    dhcp > dhcp-server (package)
    
    thank you stolidmollusc for reporting this issue.
    
    Bug 1420569 - Fedora 25 networking-guide section 9.2 has wrong package
    name for the dhcp-server package.


Note You need to log in before you can comment on or make changes to this bug.