Bug 1420600 - [RFE] support installation using Anaconda liveimg command
Summary: [RFE] support installation using Anaconda liveimg command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Retired
Component: general
Version: 24
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: 25.0
Assignee: Dan Callaghan
QA Contact: Anwesha Chatterjee
URL:
Whiteboard:
: 1215480 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 03:53 UTC by matt jia
Modified: 2018-03-19 04:19 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-19 04:19:12 UTC


Attachments (Terms of Use)

Comment 1 Dan Callaghan 2017-10-25 22:55:36 UTC
Yuval Turgeman has posted a patch for this feature here:

https://github.com/beaker-project/beaker/pull/3

so we should review that and move it (or help Yuval to move it) onto Gerrit.

Comment 2 Dan Callaghan 2017-11-30 03:41:42 UTC
This is on Gerrit now as https://gerrit.beaker-project.org/5922

Comment 3 Anwesha Chatterjee 2018-01-16 22:24:25 UTC
Reverting to POST as missing bug footer in commit message is causing checkbugs failure

Comment 4 Anwesha Chatterjee 2018-01-16 23:53:10 UTC
https://gerrit.beaker-project.org/#/c/5974/ reverts the patch https://gerrit.beaker-project.org/#/c/5975/ resubmits it with a bug footer this time ;-)

Comment 6 Anwesha Chatterjee 2018-01-24 22:50:35 UTC
Verified that when the liveimg relative url is passed into the ks_meta attribute, in an RHVH provisioning job, the installation successfully locates the squashfs image.
Tested on beaker-devel, using this recipe:
  https://beaker-devel.app.eng.bos.redhat.com/recipes/20700#installation

Comment 7 Anwesha Chatterjee 2018-01-24 23:00:46 UTC
... Although, please note that beakerlib can't be installed because the testing RHVH4 distro does not have wget and net-tools

Comment 9 Dan Callaghan 2018-01-25 10:02:24 UTC
Interestingly, the dependency problems with beakerlib then also cause beah itself to fail to be installed, so the recipe never runs.

It might be worth separating those into separate yum transactions. So install beah and rhts-test-env first, then beakerlib, then beakerlib-redhat. In case either of the latter two fail. At least then the recipe would still run.

The question of why beakerlib requires wget and net-tools is maybe not as easy to solve, we should run it by Dalibor...

Comment 12 Roman Joost 2018-02-01 02:39:46 UTC
Dear Dalibor,

would you be able to comment about why beakerlib requires wget and net-tools? The problem is highlighted in comment 7.

Many thanks!

Comment 13 Dan Callaghan 2018-02-06 01:53:47 UTC
(In reply to Dan Callaghan from comment #9)
> It might be worth separating those into separate yum transactions. So
> install beah and rhts-test-env first, then beakerlib, then beakerlib-redhat.
> In case either of the latter two fail. At least then the recipe would still
> run.

https://gerrit.beaker-project.org/5991

Comment 15 Anwesha Chatterjee 2018-02-22 04:51:54 UTC
https://beaker-devel.app.eng.bos.redhat.com/recipes/20834#installation

Verified that installation succeeds by running above job.

Comment 16 Roman Joost 2018-03-08 02:57:40 UTC
*** Bug 1215480 has been marked as a duplicate of this bug. ***

Comment 17 Roman Joost 2018-03-19 04:19:12 UTC
Beaker 25.0 has been released.

Release notes are available upstream: https://beaker-project.org/docs/whats-new/release-25.html


Note You need to log in before you can comment on or make changes to this bug.