Bug 1420611 - when server-quorum is enabled, volume get returns 0 value for server-quorum-ratio
Summary: when server-quorum is enabled, volume get returns 0 value for server-quorum-r...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1323928 1420989
TreeView+ depends on / blocked
 
Reported: 2017-02-09 04:46 UTC by Atin Mukherjee
Modified: 2017-05-30 18:41 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1323928
: 1420989 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:41:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2017-02-09 04:46:09 UTC
+++ This bug was initially created as a clone of Bug #1323928 +++

Description of problem:
-----------------------
When server-side quorum is enabled on the volume, the default value of server-quorum-ratio should be 50%

But 'gluster volume get' returns the value as 0

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1.2 ( glusterfs-3.7.5-19.el7rhgs )

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Enable server-quorum on the volume
2. get the server-quorum-ratio

Actual results:
---------------
server-quorum ratio value retrieved using gluster volume get is 0

Expected results:
-----------------
server-quorum ration value should be 50% using the gluster volume get, when just the server-quorum is enabled on the volume

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-04-05 02:08:12 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-07-04 04:53:17 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Rejy M Cyriac on 2016-09-17 12:34:26 EDT ---

Moving BZ to a transitional component in preparation for removing the 'glusterd' sub-component at the 'glusterd' component

--- Additional comment from Rejy M Cyriac on 2016-09-17 12:47:36 EDT ---

Moving BZ back to the 'glusterd' component after removal of the 'glusterd' sub-component

--- Additional comment from Atin Mukherjee on 2017-01-11 02:26:59 EST ---

Comment 1 Worker Ant 2017-02-09 04:47:13 UTC
REVIEW: https://review.gluster.org/16572 (glusterd: set default GLUSTERD_QUORUM_RATIO_KEY value to 50) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Worker Ant 2017-02-09 04:51:14 UTC
REVIEW: https://review.gluster.org/16572 (glusterd: set default GLUSTERD_QUORUM_RATIO_KEY value to 51) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Worker Ant 2017-02-09 14:27:01 UTC
REVIEW: https://review.gluster.org/16572 (glusterd: set default GLUSTERD_QUORUM_RATIO_KEY value to 51) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Worker Ant 2017-02-09 16:41:48 UTC
COMMIT: https://review.gluster.org/16572 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 9385d3409054f21c7b936ad62b9a67728c31d839
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 9 10:13:20 2017 +0530

    glusterd: set default GLUSTERD_QUORUM_RATIO_KEY value to 51
    
    The default value of GLUSTERD_QUORUM_RATIO_KEY is set to 0, while this
    doesn't harm any functionality as the actual quorum calculation logic
    always take the factor that if the key is not set in the dictionary the
    value is considered to be 51 but from an user perspective it gives an
    incorrect output through volume get where quorum-ratio is always shown as
    0 until reconfigured.
    
    Change-Id: I087712fa4736055859f29cc3bdbb3b111cbe7224
    BUG: 1420611
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16572
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 5 Shyamsundar 2017-05-30 18:41:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.