Bug 1420619 - Entry heal messages in glustershd.log while no entries shown in heal info
Summary: Entry heal messages in glustershd.log while no entries shown in heal info
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sunil Kumar Acharya
QA Contact:
URL:
Whiteboard:
Depends On: 1282731
Blocks: 1422766 1422783
TreeView+ depends on / blocked
 
Reported: 2017-02-09 05:44 UTC by Sunil Kumar Acharya
Modified: 2017-05-30 18:41 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1282731
: 1422766 1422783 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:41:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Ashish Pandey 2017-02-09 06:09:09 UTC
Description of problem:
=======================

This is a logging issue. After replace-brick, glustershd log shows entry heal successful messages while no entries are shown with heal info command. These are informatory messages.

[2015-11-17 09:09:17.262558] I [MSGID: 122058] [ec-heal.c:2338:ec_heal_do] 0-vol1-disperse-0: /files/dir.8/newfile.79: name heal successful on FFF
[2015-11-17 09:09:17.457770] I [MSGID: 122058] [ec-heal.c:2338:ec_heal_do] 0-vol1-disperse-0: /files/dir.8/newfile.80: name heal successful on FFF
[2015-11-17 09:09:17.597917] I [MSGID: 122058] [ec-heal.c:2338:ec_heal_do] 0-vol1-disperse-0: /files/dir.9/newfile.94: name heal successful on FFF
[2015-11-17 09:09:17.625835] I [MSGID: 122058] [ec-heal.c:2338:ec_heal_do] 0-vol1-disperse-0: /files/dir.8/newfile.81: name heal successful on FFF
[2015-11-17 09:09:18.067542] I [MSGID: 122058] [ec-heal.c:2338:ec_heal_do] 0-vol1-disperse-0: /files/dir.8/newfile.82: name heal successful on FFF
[2015-11-17 09:09:18.348196] I [MSGID: 122058] [ec-heal.c:2338:ec_heal_do] 0-vol1-disperse-0: /files/dir.9/newfile.95: name heal successful on FFF


Version-Release number of selected component (if applicable):
=============================================================
3.7.5-6

[root@transformers ~]# gluster --version
glusterfs 3.7.5 built on Nov 10 2015 00:13:38
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
=================
glustershd should show the entries only for the files which get healed.

Additional info:

Comment 2 Worker Ant 2017-02-09 11:14:07 UTC
REVIEW: https://review.gluster.org/16580 (cluster/ec: Change log level of messages to DEBUG) posted (#1) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 3 Worker Ant 2017-02-09 11:23:45 UTC
REVIEW: https://review.gluster.org/16580 (cluster/ec: Change log level of messages to DEBUG) posted (#2) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 4 Worker Ant 2017-02-10 06:32:02 UTC
REVIEW: https://review.gluster.org/16580 (cluster/ec: Change log level of messages to DEBUG) posted (#3) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 5 Worker Ant 2017-02-10 10:34:51 UTC
REVIEW: https://review.gluster.org/16580 (cluster/ec: Change log level of messages to DEBUG) posted (#4) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 6 Worker Ant 2017-02-15 07:22:31 UTC
COMMIT: https://review.gluster.org/16580 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit a6ece44d0bbdecf38252f477b4aa98a76771a328
Author: Sunil Kumar Acharya <sheggodu@redhat.com>
Date:   Thu Feb 9 16:34:54 2017 +0530

    cluster/ec: Change log level of messages to DEBUG
    
    Heal failed or passed should not be logged as info. These can be
    observed from heal info if the heal is happening or not. If we require
    to debug a case where heal is not happening, we can set the level to
    DEBUG.
    
    Change-Id: I062668eadd145ef809b25e818e6bca1094f54cd6
    BUG: 1420619
    Signed-off-by: Sunil Kumar Acharya <sheggodu@redhat.com>
    Reviewed-on: https://review.gluster.org/16580
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ashish Pandey <aspandey@redhat.com>

Comment 7 Shyamsundar 2017-05-30 18:41:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.