Bug 1420620 - open-vm-tools should depend on perl
Summary: open-vm-tools should depend on perl
Keywords:
Status: CLOSED DUPLICATE of bug 1358108
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: open-vm-tools
Version: 7.3
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 05:49 UTC by Eugene Peregudov
Modified: 2017-02-09 10:28 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 10:28:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eugene Peregudov 2017-02-09 05:49:09 UTC
Description of problem:
deployPkg plug-in uses /usr/bin/perl for VM customization, but open-vm-tools package does not depend on perl package.

Version-Release number of selected component (if applicable):
open-vm-tools-10.0.5-2.el7.x86_64

Actual results:
VM with minimal RHEL 7.3 guest OS and installed open-vm-tools did not customized by vCloud Director, because perl is not installed as dependency for open-vm-tools

Expected results:
VM with minimal RHEL 7.3 guest OS and installed open-vm-tools customized by vCloud Director.

Additional info:
1) cat /var/log/vmware-imc/toolsDeployPkg.log

ENTER STATE INPROGRESS

Reading cabinet file /tmp/vmware-root/46dd98e5/imc2585.tmp.

Creating directory /tmp
Creating directory /tmp/.vmware
Creating directory /tmp/.vmware/linux
Creating directory /tmp/.vmware/linux/deploy
Extracting package files.

Launching deployment /usr/bin/perl -I/tmp/.vmware/linux/deploy/scripts /tmp/.vmware/linux/deploy/scripts/Customize.pl /tmp/.vmware/linux/deploy/cust.cfg.

2) If you are using RHEL7 minimal or CentOS7 minimal, Perl must be installed for customization to function.
https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2075048

3) We need to add perl as a dependency to the package to avoid this in future.
https://github.com/vmware/open-vm-tools/issues/56

Comment 1 Richard W.M. Jones 2017-02-09 10:28:56 UTC

*** This bug has been marked as a duplicate of bug 1358108 ***


Note You need to log in before you can comment on or make changes to this bug.