Bug 1420646 - Upgrade failed when use temp_skip_router_registry_upgrade
Summary: Upgrade failed when use temp_skip_router_registry_upgrade
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Chaloupka
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 07:24 UTC by Anping Li
Modified: 2017-02-20 01:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-20 01:25:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Anping Li 2017-02-09 07:24:10 UTC
Description of problem:
The upgrade failed when set temp_skip_router_registry_upgrade=true in inventory file

Version-Release number of selected component (if applicable):
openshift-ansible:master

How reproducible:
always

Steps to Reproduce:
1.  install OCP 3.4 
2.   set temp_skip_router_registry_upgrade=true; upgrade OCP 3.5 to OCP 3.5
    ansible-playbook -i /root/workdir/hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_5/upgrade_control_plane.yml -vvv


Actual results:
TASK [Collect all routers] *****************************************************
task path: /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/upgrades/post_control_plane.yml:33
skipping: [openshift-212.example.com] => {
    "changed": false,
    "skip_reason": "Conditional check failed",
    "skipped": true
}

TASK [set_fact] ****************************************************************
task path: /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/upgrades/post_control_plane.yml:41
fatal: [openshift-212.example.com]: FAILED! => {
    "failed": true
}

MSG:

Unexpected templating type error occurred on ({{ (all_routers.stdout | from_json)['items'] | oo_pods_match_component(openshift_deployment_type, 'haproxy-router') | oo_select_keys_from_list(['metadata']) }}): expected string or buffer
        to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_5/upgrade_control_plane.retry

PLAY RECAP *********************************************************************
localhost                  : ok=32   changed=0    unreachable=0    failed=0
openshift-211.example.com : ok=62   changed=1    unreachable=0    failed=0
openshift-212.example.com : ok=218  changed=15   unreachable=0    failed=1

Expected results:


Additional info:

Comment 2 Anping Li 2017-02-14 02:15:13 UTC
The requirement will changed, so the bug may be closed later.

Comment 3 Steve Milner 2017-02-16 19:34:42 UTC
Based on changes since this was opened I believe this will now work. Specifically the added line in the file:

    - temp_skip_router_registry_upgrade is not defined

which was added on 13-02-2017. Can you verify?

Comment 6 Anping Li 2017-02-20 01:25:19 UTC
The feature was revert in upstream. so close it.


Note You need to log in before you can comment on or make changes to this bug.