Bug 1420651 - foreman-tasks startup returns quickly, but "hammer ping" shows failed state until startup is complete
Summary: foreman-tasks startup returns quickly, but "hammer ping" shows failed state u...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Tasks Plugin
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jan Hutař
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 07:52 UTC by Chris Duryee
Modified: 2021-03-11 14:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-01 12:07:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1538688 0 medium CLOSED 'hammer ping' can erroneously say foreman-tasks is down when its just busy 2021-03-11 17:01:21 UTC

Internal Links: 1538688

Description Chris Duryee 2017-02-09 07:52:19 UTC
Description of problem:

If you run "service foreman-tasks start", this will kick off foreman-tasks. However, "hammer ping" will return "fail" for foreman-tasks for a few dozen seconds after the systemctl script has returned. This makes it appear as if startup has failed.

After 10-30 seconds, "hammer ping" will show success for foreman-tasks, and things will operate normally. While this is a minor issue, the delay can be enough time for the user to think something is wrong and start checking log files, only to retry the hammer ping and get a success message.

Version-Release number of selected component (if applicable): 6.2.7


Steps to Reproduce:
1. service foreman-tasks stop
2. service foreman-tasks start
3. hammer ping

Actual results:

candlepin:      
    Status:          ok
    Server Response: Duration: 19ms
candlepin_auth: 
    Status:          ok
    Server Response: Duration: 19ms
pulp:           
    Status:          ok
    Server Response: Duration: 26ms
foreman_tasks:  
    Status:          FAIL
    Server Response:


Expected results:

foreman_tasks should be successful immediately, or the service script should wait

Comment 2 Adam Ruzicka 2017-10-11 09:20:31 UTC
Created redmine issue http://projects.theforeman.org/issues/21294 from this bug

Comment 3 pm-sat@redhat.com 2018-08-02 15:46:53 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/21294 has been resolved.

Comment 7 Ivan Necas 2018-12-11 12:26:22 UTC
I think there was a misunderstanding of this bug and the fix. I think the correct BZ the attached issues is meant to solve is this in https://bugzilla.redhat.com/show_bug.cgi?id=1538688.

@adam: can you recall a reason why this BZ was linked to corresponding patch? It doesn't look like it could fix this particular problem.

Comment 8 pm-sat@redhat.com 2018-12-11 13:04:34 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/21294 has been resolved.

Comment 9 Adam Ruzicka 2018-12-11 15:32:50 UTC
Nothing sensible comes to my mind, probably just human error.

Comment 10 Ivan Necas 2018-12-11 15:39:54 UTC
Ok, updated the upstream issue accordingly

Comment 12 Bryan Kearney 2019-02-28 19:39:54 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 13 Bryan Kearney 2019-04-01 12:07:06 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 14 Bryan Kearney 2019-04-02 13:33:48 UTC
Wrond closure reason.


Note You need to log in before you can comment on or make changes to this bug.