Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1420659 - when viewing a host from "all hosts" page, user is unable to go back without hitting browser back button
Summary: when viewing a host from "all hosts" page, user is unable to go back without ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Perry Gagne
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 08:31 UTC by Chris Duryee
Modified: 2019-08-12 16:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-03 19:19:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 20345 0 None None None 2017-07-19 09:43:40 UTC
Red Hat Bugzilla 1622588 0 unspecified CLOSED Using Breadcrumb bar to go back to Host listing does not preserve search. 2021-02-22 00:41:40 UTC

Internal Links: 1622588

Description Chris Duryee 2017-02-09 08:31:51 UTC
Description of problem:

If you go to the "all hosts" page and then click on a host, it is not possible to go back to the "all hosts" view without using the browser back button.

Version-Release number of selected component (if applicable): 6.2.7


Steps to Reproduce:
1. in "all hosts" page, perform a search for a host
2. click host
3. attempt to go back to the search you performed

Actual results: user needs to click browser "back" button to go back to search performed

Expected results: user can click some UI element to go back, similar to "close" button on host content page

Comment 3 Tomer Brisker 2017-07-19 09:43:38 UTC
Created redmine issue http://projects.theforeman.org/issues/20345 from this bug

Comment 4 Satellite Program 2017-07-19 10:14:07 UTC
Upstream bug assigned to tbrisker@redhat.com

Comment 5 Satellite Program 2017-07-19 10:14:11 UTC
Upstream bug assigned to tbrisker@redhat.com

Comment 6 Satellite Program 2017-07-20 18:02:03 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20345 has been resolved.

Comment 7 Satellite Program 2017-07-20 18:13:43 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20345 has been resolved.

Comment 8 Chris Brown 2018-06-21 19:14:26 UTC
In Satellite 6.4, on a page to edit a host the Back button in the UI and the Hosts breadcrumb both go back to the All Hosts page but not to the search query that was performed. Is this expected for this bug?

Comment 18 Bryan Kearney 2018-10-03 19:19:41 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.