Bug 1420687 - Remove NFS & CIFS checkboxes and enable optimize-for-virt-store in the volume creation dialog
Summary: Remove NFS & CIFS checkboxes and enable optimize-for-virt-store in the volume...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.1.0.3
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.1.2
: 4.1.1
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
: 1429349 (view as bug list)
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-02-09 10:13 UTC by SATHEESARAN
Modified: 2019-04-28 11:15 UTC (History)
3 users (show)

Fixed In Version: 4.1.1-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-23 08:22:50 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
sabose: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
Screenshot of the volume create dialog (44.67 KB, image/png)
2017-02-09 10:15 UTC, SATHEESARAN
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 72824 master MERGED webadmin: Default values for volume create 2017-02-22 05:33:51 UTC
oVirt gerrit 72847 ovirt-engine-4.1 MERGED webadmin: Default values for volume create 2017-02-22 12:22:50 UTC

Description SATHEESARAN 2017-02-09 10:13:40 UTC
Description of problem:
-----------------------
With Hyperconverged mode on, the volume creation dialog should not contain, NFS & CIFS to be turned on by default. With RHGS 3.2.0, NFS server is disabled by default on glusterfs volumes, in favour of NFS ganesha.

So, it no longer makes sense to have the NFS and CIFS checkboxed in the volumes creation dialog.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
oVirt-4.1.0.3

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Create a hyperconverged cluster with gluster and virt services enabled
2. Create a volume.
3. Observe the volume create dialog

Actual results:
---------------
There are checkboxes with the names NFS & CIFS checked by default, meaning that NFS and CIFS services are enabled on the volume

Expected results:
-----------------
Remove the NFS & CIFS checkboxes

Comment 1 SATHEESARAN 2017-02-09 10:15:50 UTC
Created attachment 1248771 [details]
Screenshot of the volume create dialog

Comment 2 SATHEESARAN 2017-02-09 10:27:30 UTC
There is also the checkbox for optimizing the volume for virt-store, which by default was not checked. This checkbox too should be checked by default.

Updated the bug summary accordingly

Comment 3 SATHEESARAN 2017-02-09 10:28:15 UTC
Note: There is no oVirt 4.1.z flag to propose this bug

Comment 4 SATHEESARAN 2017-03-09 05:20:03 UTC
*** Bug 1429349 has been marked as a duplicate of this bug. ***

Comment 6 SATHEESARAN 2017-05-17 06:37:01 UTC
Tested with RHV 4.1.2-2.

When creating the gluster volume with the cluster with both virt and gluster capability enabled, 'NFS' & 'CIFS' checkboxes are unchecked, and 'Optimize for Virt Store' is checked by default


Note You need to log in before you can comment on or make changes to this bug.