Bug 1420709 - Mate desktop redraw issues
Summary: Mate desktop redraw issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-desktop
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 11:04 UTC by Yves L'ECUYER
Modified: 2017-04-02 09:31 UTC (History)
3 users (show)

Fixed In Version: mate-desktop-1.16.2-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-29 01:31:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Yves L'ECUYER 2017-02-09 11:04:27 UTC
Description of problem:
=======================
Once Fedora 25 is installed with the spin Compiz + MATE, 
=> either with migration from Fedora 24 (or 23)
=> or in a fresh install 
Once loggued in Mate desktop, and compiz started,
  1) the desktop background disappear and became black
  2) when you move a windows, you have trailing shadow on desktop
  (illustrated as on github discussion: 
      https://github.com/compiz-reloaded/compiz/issues/40)
  3) When you rotate the desktop, even at the end of rotation, it remains    
     transparent , and we saw the skydome backgroud of compiz if skydome is 
     activated

On Fedora 25 , the extra display manager KDM has been installed, and chosen as the default display manager, so that switching from a desktop to an other is very easy, at the login step.

Besides  
mate-desktop-1.16.1-2.fc25.x86_64

are also installed :
PLASMA 5
# rpm -qa | grep plasma-desktop
plasma-desktop-5.8.5-1.fc25.x86_64
plasma-desktop-doc-5.8.5-1.fc25.noarch

RELEASE GTK3
# rpm -qa | sort | grep ^gtk3
gtk3-3.22.7-1.fc25.x86_64
gtk3-devel-3.22.7-1.fc25.x86_64
gtk3-devel-docs-3.22.7-1.fc25.x86_64
gtk3-immodule-xim-3.22.7-1.fc25.x86_64


Version-Release number of selected component (if applicable):
# rpm -qa | grep mate-desktop              
mate-desktop-libs-1.16.1-2.fc25.x86_64
mate-desktop-1.16.1-2.fc25.x86_64


How reproducible:
==================
case A) ALWAYS WITH MATE DESKTOP  AND COMPIZ ACTIVATED
case B) NEVER  WITH PLAMA DESKTOP AND COMPIZ ACTIVATED

Even if we start from runlevel 3 (no Display manager running)
once logged in ascii mode, and a graphic session started with
$ startx &

if DESKTOP="MATE" in /etc/sysconfig/desktop, I got the same case as A)
     trouble with MATE used with Compiz windows manager, 
     while is working fine with  Marco windows manager.

if DESKTOP="KDE" in /etc/sysconfig/desktop, I got the same case as B)
    No redraw issue with PLASMA 5. The rotating cube is working normallly

!!!   So DONT SAY TO ME IT's A COMPIZ ISSUE  !!
IT IS A PROBLEM WITH MATE !!!

and consequently this is NOT a duplicate bug with 
https://bugzilla.redhat.com/show_bug.cgi?id=1409385
I'm not using XFCE, neither Intel Video Card but a NVIDIA video cards.
And the problem is not related to Seamonkey as suggested in the title of this reported bugs

Steps to Reproduce:
===================
1.At login step with KDM display manager, if PLASMA is choosen and COMPIZ started the session is working perfectly

2.At login step with KDM display manager, if MATE is choosen and COMPIZ started the session is not practically usable
3.

Actual results:
MATE + COMPIZ with standard package at beginning of February 2017 is not usable

Expected results:
MATE + COMPIZ usable with the last update of MATE for Fedora 25

Additional info:
===============
I never had any of these issues with last update MATE + COMPIZ in Fedora 24.
I only see this issue in October 2016 when I migrate for the fisrt time a Fedora 24 installed machine in Fedora 25.
Of course I found the bug turn around: 
Instead of using Mate desktop management to have a backgroud, we go in Comiz management --> Utilities  --> Background
and the we choose background that normally is offered by Mate desktop management
THAT SAID IS SO SIMPLE ???
But when you are a newbie, and you have just installed Mate+Compiz SPIN, and even after a complete update it DOES NOT WORK , what he thinks about this SPIN !!!!!
+++++++++++++++++
NOW ACCORDINGLY TO https://github.com/mate-desktop/caja/pull/731
and the comment of "raveit65" : 
"No need let the users wait 6 months for a fix which comes regular with mate-1.18 for f26."

WHAT DOES THIS MEAN ? I have by myself, take the mate-1.18 RPMS from fedora 26 (Fedora rawhide) developpement, to have finally, MATE working correctly ???
Does any one tried this ?
Currently in next 15 days I'm overwhelmed by works, So I can tries this.
But after I'll make a tries with this solution

Comment 1 Wolfgang Ulbrich 2017-02-09 13:01:28 UTC
All is caused by a change by gtk3, see https://github.com/compiz-reloaded/compiz/issues/40
and report is already filled out here
https://bugzilla.gnome.org/show_bug.cgi?id=768415

And upstream is working on this , see
https://github.com/mate-desktop/mate-desktop/pull/249
https://github.com/mate-desktop/caja/pull/731
https://github.com/mate-desktop/mate-settings-daemon/pull/169
There are 1.16 branches at github with that rewrite of mate's bg handling too.
Unfortunately, fixes needs some work, currently we have a flickering with the desktop icons if you move with the mouse over it.
But i can give you a link to updated rpms for 1.16.
Believe me i will update fedora very fast if results are acceptable.

Comment 2 Wolfgang Ulbrich 2017-02-09 13:04:01 UTC
This is the origin report at rhbz
https://bugzilla.redhat.com/show_bug.cgi?id=1383272

Comment 3 Wolfgang Ulbrich 2017-02-09 13:08:07 UTC
btw. my nick name is raveit65 ;)
But please read the complete PR :-)

Comment 4 Yves L'ECUYER 2017-02-11 11:05:58 UTC
(In reply to Wolfgang Ulbrich from comment #3)
> btw. my nick name is raveit65 ;)
> But please read the complete PR :-)

Ok I have read the complete progress of Patch Reporting on https://github.com/mate-desktop
So I'll follow with interest the developer work progress !!!

But YES, I'm interested as you suggest in Comment 1, by a "work in progress current stage" of a mate-1.16*src.rpm
Thanks

Comment 5 Wolfgang Ulbrich 2017-02-11 15:28:27 UTC
Ok, here are the promised rpms/srpms.
https://dl.dropboxusercontent.com/u/49862637/Mate-desktop/Test/test.tar.xz

Comment 6 Fedora Update System 2017-03-27 03:21:01 UTC
caja-1.16.3-1.fc25, mate-desktop-1.16.2-1.fc25, mate-settings-daemon-1.16.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-75ddaab36c

Comment 7 Fedora Update System 2017-03-29 01:31:55 UTC
caja-1.16.3-1.fc25, mate-desktop-1.16.2-1.fc25, mate-settings-daemon-1.16.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Yves L'ECUYER 2017-04-02 09:31:56 UTC
 Just updated today, 2017 April 17, with current update:
# dnf update caja mate-desktop mate-settings-daemon

 caja                      x86_64      1.16.4-1.fc25         updates      1.4 M
 caja-extensions           x86_64      1.16.4-1.fc25         updates       35 k
 caja-schemas              x86_64      1.16.4-1.fc25         updates      2.0 M
 mate-desktop              x86_64      1.16.2-1.fc25         updates      109 k
 mate-desktop-libs         x86_64      1.16.2-1.fc25         updates      483 k
 mate-settings-daemon      x86_64      1.16.2-1.fc25         updates      566 k

All is working fine. 
Background can be managed normally by :
Popup menu on desktop backgroud --> Change background

An no trailing shadow when moving windows.

On the other side when using option "backgroung" in fusion-icon setting manager, the option seems disabled ? (do not change background appearance any more ) 
Well, may be that has be done on purpose ?


Note You need to log in before you can comment on or make changes to this bug.