Bug 1420713 - glusterd: storhaug, remove all vestiges ganesha
Summary: glusterd: storhaug, remove all vestiges ganesha
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1420714
TreeView+ depends on / blocked
 
Reported: 2017-02-09 11:28 UTC by Kaleb KEITHLEY
Modified: 2017-05-30 18:42 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1420714 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:42:26 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2017-02-09 11:28:25 UTC
Description of problem:

The storhaug CLI is used to manage ganesha and Samba. Also any setup and teardown of the ganesha HA is initiated using storhaug to preserve the proper layering.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-02-09 11:29:56 UTC
REVIEW: https://review.gluster.org/16504 (glusterd (storhaug): remove ganesha) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2017-02-12 14:45:14 UTC
REVIEW: https://review.gluster.org/16504 (glusterd: (storhaug) remove ganesha) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Worker Ant 2017-02-12 14:53:49 UTC
REVIEW: https://review.gluster.org/16504 (glusterd: (storhaug) remove ganesha) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Worker Ant 2017-02-12 14:58:05 UTC
REVIEW: https://review.gluster.org/16504 (glusterd: (storhaug) remove ganesha) posted (#8) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 5 Worker Ant 2017-03-20 11:41:01 UTC
REVIEW: https://review.gluster.org/16504 (glusterd: (storhaug) remove ganesha) posted (#9) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 6 Worker Ant 2017-03-21 17:13:48 UTC
COMMIT: https://review.gluster.org/16504 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 843e1b04b554ab887ec656ae7b468bb93ee4e2f7
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Feb 1 06:39:03 2017 -0500

    glusterd: (storhaug) remove ganesha
    
    remove all vestiges of ganesha
    
    The storhaug CLI is used to manage ganesha and Samba. Also any setup
    and teardown of the ganesha HA is initiated using storhaug to preserve
    the proper layering.
    
    Change-Id: I0eec0016a1b7802a36e7b2d92896b86fdf8607d5
    BUG: 1420713
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/16504
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 7 Shyamsundar 2017-05-30 18:42:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.