Bug 1420790 - No linking to libsnappy.so
Summary: No linking to libsnappy.so
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: snappy-java
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: gil cattaneo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1370900
TreeView+ depends on / blocked
 
Reported: 2017-02-09 13:58 UTC by Tomas Repik
Modified: 2017-02-17 20:51 UTC (History)
4 users (show)

Fixed In Version: snappy-java-1.1.2.4-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-17 20:51:53 UTC
Type: Bug


Attachments (Terms of Use)
linking_fix (3.42 KB, patch)
2017-02-09 13:58 UTC, Tomas Repik
no flags Details | Diff

Description Tomas Repik 2017-02-09 13:58:49 UTC
Created attachment 1248817 [details]
linking_fix

Description of problem:
When i wanted to update the ohc package, which depends on snappy-java I ran into problems in tests. At first I ignored it and skipped the tests but then I started to look into the error. The message I got was:

/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.101-2.b14.fc26.x86_64/jre/bin/java: symbol lookup error: /tmp/snappy-1.1.2.4-a36a540c-a5ee-471b-a91c-a2ec39e1703e-libsnappyjava.so: undefined symbol: _ZN6snappy19MaxCompressedLengthEm

At first I thought it was an ohc issue [1], but upstream proved me wrong. So I thought it was some bug in snappy-java [2] upstream but once again i was wrong. Today with help from praiskup we figured out that the new snappy-java is not linking to libsnappy.so.

I provide a patch to fix the issue.

Version-Release number of selected component (if applicable):
snappy-java-1.1.2.4 in both f25 rawhide

[1] https://github.com/snazy/ohc/issues/25
[2] https://github.com/xerial/snappy-java/issues/150

Comment 1 Pavel Raiskup 2017-02-09 14:34:52 UTC
Gil, I bet the problem is in F25+.

Comment 2 gil cattaneo 2017-02-09 14:38:22 UTC
Sure. Now is available in rawhide.
Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=17691470

Comment 3 Fedora Update System 2017-02-09 14:59:42 UTC
snappy-java-1.1.2.4-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e2fc070714

Comment 4 Fedora Update System 2017-02-10 00:50:39 UTC
snappy-java-1.1.2.4-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e2fc070714

Comment 5 Fedora Update System 2017-02-17 20:51:53 UTC
snappy-java-1.1.2.4-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.