Bug 1420797 - NetworkManager cannot connect to wifi after 4.8.x --> 4.9.x upgrade
Summary: NetworkManager cannot connect to wifi after 4.8.x --> 4.9.x upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 14:22 UTC by Saša Janiška
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-20 16:20:59 UTC
Type: Bug


Attachments (Terms of Use)
content of: journalctl -f -n 0 | tee connection.log while NM tries to connect (38.81 KB, text/x-vhdl)
2017-02-09 14:22 UTC, Saša Janiška
no flags Details

Description Saša Janiška 2017-02-09 14:22:26 UTC
Created attachment 1248818 [details]
content of: journalctl -f -n 0 | tee connection.log while NM tries to connect

Description of problem:

After upgrading my netbook from 4.8.x kernel to 4.9.x series, NetworkManager cannot connect any longer...I'm including the log file.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

$ dmesg | grep rtl8192
16.338693] rtl8192ce: Using firmware rtlwifi/rtl8192cfw.bin
[   18.020950] rtl8192ce 0000:01:00.0 wlp1s0: renamed from wlan0


snippet from lspci -k:

01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
        Subsystem: Realtek Semiconductor Co., Ltd. Device 8195
        Kernel driver in use: rtl8192ce
        Kernel modules: rtl8192ce

Comment 1 Saša Janiška 2017-02-09 14:24:07 UTC
Forgot to add that NM does not properly populate

/etc/resolv.conf

since there is no longer:

nameserver w.x.y.z 

entry.

Comment 2 Laura Abbott 2017-02-09 20:21:29 UTC
Can you test on a rawhide kernel? The maintainers mentioned there was a fix https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=52f5631a4c05 that might cause problems

Comment 3 Saša Janiška 2017-02-10 09:32:59 UTC
Tried with 4.10.0-0.rc7.git3.1.fc26 kernel and it does work!

Comment 4 Troels Arvin 2017-02-20 08:40:10 UTC
Confirming Saša's observation: Installing kernel-4.10.0-0.rc8.git2.1.fc26 from https://koji.fedoraproject.org/koji/packageinfo?packageID=8 made the problem go away.

Comment 5 Laura Abbott 2017-02-20 16:20:59 UTC
This fix is now in stable releases. Thanks for reporting and testing.


Note You need to log in before you can comment on or make changes to this bug.