Bug 1420805 - nordugrid-arc: FTBFS with libs3-4.0-0.1.20170206git208bcba.fc26
Summary: nordugrid-arc: FTBFS with libs3-4.0-0.1.20170206git208bcba.fc26
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nordugrid-arc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
: 1424000 (view as bug list)
Depends On:
Blocks: F26FTBFS
TreeView+ depends on / blocked
 
Reported: 2017-02-09 14:38 UTC by Jitka Plesnikova
Modified: 2017-02-21 20:39 UTC (History)
3 users (show)

Fixed In Version: nordugrid-arc-5.3.0-0.4.rc1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-21 20:37:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Jitka Plesnikova 2017-02-09 14:38:09 UTC
Description of problem:
Package nordugrid-arc fails to build from source against libs3-4.0-0.1.20170206git208bcba.fc26 in Fedora Rawhide 

Version-Release number of selected component (if applicable):
5.3.0-0.2.rc1.fc26

Steps to Reproduce:
koji build --scratch f26 nordugrid-arc-5.3.0-0.2.rc1.fc26.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/nordugrid-arc

The failures are related to the following commit in libs3:

commit 552a45a9bcdfe18b139cfabd428694bca4ec756e
Author:     Andrei Kopats <andrei.kopats@synesis.ru>
AuthorDate: Fri Feb 3 18:11:57 2017 +0300
Commit:     Andrei Kopats <andrei.kopats@synesis.ru>
CommitDate: Fri Feb 3 18:11:57 2017 +0300

    set request timeout for all functions

Example of errors:
DataPointS3.cpp: In member function 'virtual Arc::DataStatus ArcDMCS3::DataPointS3::Stat(Arc::FileInfo&, Arc::DataPoint::DataPointInfoType)':
DataPointS3.cpp:302:60: error: invalid conversion from 'S3ResponseHandler*' to 'int' [-fpermissive]
     S3_head_object(&bucketContext, key_name.c_str(), NULL, &responseHandler,
                                                            ^~~~~~~~~~~~~~~~
DataPointS3.cpp:303:25: error: cannot convert 'Arc::FileInfo*' to 'const S3ResponseHandler*' for argument '5' to 'void S3_head_object(const S3BucketContext*, const char*, S3RequestContext*, int, const S3ResponseHandler*, void*)'
                    &file);
                         ^
DataPointS3.cpp: In member function 'virtual Arc::DataStatus ArcDMCS3::DataPointS3::List(std::__cxx11::list<Arc::FileInfo>&, Arc::DataPoint::DataPointInfoType)':
DataPointS3.cpp:371:60: error: invalid conversion from 'S3ResponseHandler*' to 'int' [-fpermissive]
     S3_head_object(&bucketContext, key_name.c_str(), NULL, &responseHandler,
                                                            ^~~~~~~~~~~~~~~~
DataPointS3.cpp:372:25: error: cannot convert 'Arc::FileInfo*' to 'const S3ResponseHandler*' for argument '5' to 'void S3_head_object(const S3BucketContext*, const char*, S3RequestContext*, int, const S3ResponseHandler*, void*)'
                    &file);
                         ^

Comment 1 Jitka Plesnikova 2017-02-09 15:05:34 UTC
And this commit in libs3 is also related to the failures.

commit 34d11b2e0f1440faa6230dc0d8312439022e5efb
Author:     Eric Stadtherr <estadtherr@caci.com>
AuthorDate: Thu Sep 29 19:10:26 2016 -0600
Commit:     Eric Stadtherr <estadtherr@caci.com>
CommitDate: Thu Sep 29 19:10:26 2016 -0600

    add auth. region to relevant API calls

Comment 2 Mattias Ellert 2017-02-21 20:39:45 UTC
*** Bug 1424000 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.