Bug 1420806 - CFME Middleware Provider Refresh TImeout
Summary: CFME Middleware Provider Refresh TImeout
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: Beta 1
: cfme-future
Assignee: Jirka Kremser
QA Contact: Matt Mahoney
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 14:44 UTC by Matt Mahoney
Modified: 2017-12-05 15:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-28 14:27:00 UTC
Category: ---
Cloudforms Team: Middleware
Target Upstream Version:


Attachments (Terms of Use)
evm.log (1.62 MB, text/plain)
2017-02-09 14:44 UTC, Matt Mahoney
no flags Details
middleware-manager.log (141.62 KB, text/plain)
2017-02-09 14:45 UTC, Matt Mahoney
no flags Details
worksforme (586.60 KB, image/png)
2017-03-28 14:30 UTC, Jirka Kremser
no flags Details

Description Matt Mahoney 2017-02-09 14:44:30 UTC
Created attachment 1248822 [details]
evm.log

Description of problem:
Middleware Provider Refresh Timeout Error:

Error - 1 Minute Ago
Timed out reading data from server 


Version-Release number of selected component (if applicable):
Middleware Manager: DR1
CFME: 5.8.0.0.20170201144150_848e68b (launched via Sprout)

How reproducible:
Most all of the time - but have experienced an attempt when Refresh of Middleware Provider did not time out.

Steps to Reproduce:
1. Start up Hawkular Manager and Cassandra instances:
https://docs.engineering.redhat.com/display/JP/CloudForms+Middleware+-+Quickstart+Guide
2.Start up CFME 5.8 instance
3.Add Middeleware Provider, and the Refresh 

Actual results:
Provider Refresh Error.

Expected results:
Refresh should succeed.

Additional info:

Comment 1 Matt Mahoney 2017-02-09 14:45:08 UTC
Created attachment 1248823 [details]
middleware-manager.log

Comment 3 Jirka Kremser 2017-03-28 14:27:00 UTC
Unable to reproduce. I used the docker images mentioned in the https://docs.engineering.redhat.com/display/JP/CloudForms+Middleware+-+Quickstart+Guide and everything works well together. The quickstart mentions uses implicitly the :latest tags, so as for the CF image it deployed the version 5.8.0.7.20170321164727_1c97ccd.

I had no exceptions in the log. So either it's been solved for the new version or I had just luck. btw. I've tried to reproduce it twice.

Comment 4 Jirka Kremser 2017-03-28 14:30:19 UTC
Created attachment 1266993 [details]
worksforme


Note You need to log in before you can comment on or make changes to this bug.