Bug 1420822 - Child type container_t exceeds bounds of parent container_runtime_t
Summary: Child type container_t exceeds bounds of parent container_runtime_t
Keywords:
Status: CLOSED DUPLICATE of bug 1420096
Alias: None
Product: Fedora
Classification: Fedora
Component: container-selinux
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 15:08 UTC by Igor Gnatenko
Modified: 2017-02-09 15:36 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 15:36:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Igor Gnatenko 2017-02-09 15:08:28 UTC
Upgrading   : container-selinux-2:2.7-1.fc26.noarch                                                                                                                                                        37/74 
Child type container_t exceeds bounds of parent container_runtime_t
  (allow container_t container_t (capability2 (mac_override mac_admin)))
    <root>
    booleanif at /var/lib/selinux/targeted/tmp/modules/100/virt/cil:2721
    true at /var/lib/selinux/targeted/tmp/modules/100/virt/cil:2722
    allow at /var/lib/selinux/targeted/tmp/modules/100/virt/cil:2723
      (allow container_t self (capability2 (mac_override mac_admin syslog wake_alarm block_suspend audit_read epolwakeup)))
  (allow container_t container_t (capability (sys_module)))
    <root>
    booleanif at /var/lib/selinux/targeted/tmp/modules/100/virt/cil:2721
    true at /var/lib/selinux/targeted/tmp/modules/100/virt/cil:2722
    allow at /var/lib/selinux/targeted/tmp/modules/100/virt/cil:2724
      (allow container_t self (capability (chown dac_override dac_read_search fowner fsetid kill setgid setuid setpcap linux_immutable net_bind_service net_broadcast net_admin net_raw ipc_lock ipc_owner sys_module sys_rawio sys_chroot sys_ptrace sys_pacct sys_admin sys_boot sys_nice sys_resource sys_time sys_tty_config mknod lease audit_write audit_control setfcap)))
Failed to generate binary
/usr/sbin/semodule:  Failed!

Are you testing this package at all?

Comment 1 Yanko Kaneti 2017-02-09 15:36:34 UTC

*** This bug has been marked as a duplicate of bug 1420096 ***


Note You need to log in before you can comment on or make changes to this bug.